Hyundai Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2001 Santa Fe 4WD 2.7L V6 with 104,000 miles roughly, and am experiencing some frustrating throttle and shifting issues. Back a few months ago (in July), suddenly it would not shift right. In fact, it wouldn't shift at all, unless I put the transmission into the slap-stick mode, so I could control it. I had the computer read, and the codes came back relating to high RPM and throttle body issues. I cleaned the throttle body well, and this helped some. Since I purchased the vehicle back in September 2012, it does take a few turns of the key at times to start. After doing some research, I found it was an issue with the Throttle Position Sensor (TPS). I went and bought a new one at NAPA (aftermarket/OEM), replaced it, and the issue seemed fixed. When I replaced it, all I did was remove the old one, disconnect the battery, install the new one, connect the new one, and reconnect the battery. Not long after doing this, the same problem started again. Other research told me a battery/electrical reset (disconnecting the negative connection, leaving off for a few moments, and then re-connecting) would fix it, and this did. However, it came back again, then I tried cleaning out the "garbage" in the system by disconnecting both ports of the battery, touching the negative and positive connectors together, then re-connecting the battery. This seemed to help again. However, recently, the issue keeps coming back. I don't want to put any more money into this thing until I know exactly what's going on. I haven't removed or cleaned any other parts. I am looking to see if anyone else has ever had this problem, or knows what could fix it. Current symptoms are: car doesn't shift on its own (or shifts after reaching 4000+ rpm, when coasting, car slows down considerably fast, and is very jerky (almost sense of whiplash with how rough it goes into accelerating and de-celerating), if it is put into cruise, this just gets worse, and it fluctuates between 2250 and 1750 rpms consistently, the Santa Fe idles fairly high (usually around 2000 rpm and maybe will go down to about 1600 RPM after a few minutes of idle), it still takes a few times to start the engine (sounds like a throttle issue/engine not getting enough gas when it's trying to start). The other thing I notice when this issue happens is the gas mileage. My gas mileage seems to drop a few (3-6) mpg when I have to operate the Santa Fe when the throttle issue occurs. Any help, ideas, or assistance would be extremely appreciated for this. Thanks!
 
1 - 1 of 1 Posts
Top