Hyundai Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My sonata has been having trouble accelerating lately. I'll pull out and start accelerating and it'll only get up to about 15 mph and not want to shift. Then it will kick into the next gear and have the same problem.

I took it to auto zone and had the codes pulled. They gave me P0115 ECT Sensor and P0705 Transaxle range signal Malfunction

Which one of those is the problem? From what I have read it sounds just like the ECT sensor.

If it is the sensor I need help finding it. I think I know which one it is but I would like to see a picture of it location to be sure. I haven't been able to find very much on google about it. And is there any fluids I need to drain, and which fluid?

I'm not a mechanic or anything so I may not fully understand your terminology. Thanks for any help.
 

·
Registered
Joined
·
17 Posts
Hyundai

I own a 2.4 L Sonata, so if yours is the same, here is what you have to do. If you are changing ECT it will be located on the ride side of your engine when you are facing the car. It is near one of the hoses coming from the radiator and the thread is golden looking. Unplug the connector and get a 14mm wrench I believe it was. I would recommend you drain the fluid first even though you can skip that.

Here is the location of the ECT sensor:



If you want to drain the fluid there is a screw on the bottom of the radiator just get a screwdriver and undo it.

Good luck !
 
1 - 3 of 3 Posts
Top