Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Car just seems like its not getting gas. I took it to a small shop and they said they didn't want anything to do with it. Too many codes. They replaced the Cam Shaft Sensor but still not luck. Also when filled up with gas has trouble starting. Here are the codes he gave me:

PO340: CamShaft Position Sensor.......already replaced still having problems
P1166: Undefined
PO440: Evaporative Emission Control System
UoDoo: Undefined
PO711: Transmission Fluid Temp Sensor circuit performance
P 2300: Undefined

Please help......I know I should take it into the dealership, but I am so cash poor right now.....I work full time and go to school paying for it on my own and I just need some help......My brother is a dodge mechanic and says he can probably replace any part necessary just doesn't have the right scanner I guess to figure out this issue please help.
 

·
Registered
Joined
·
17,552 Posts
QUOTE (ryanfann @ Jun 26 2010, 02:59 PM) index.php?act=findpost&pid=336364
Car just seems like its not getting gas. I took it to a small shop and they said they didn't want anything to do with it. Too many codes. They replaced the Cam Shaft Sensor but still not luck. Also when filled up with gas has trouble starting. Here are the codes he gave me:

PO340: CamShaft Position Sensor.......already replaced still having problems
Replaced and still come back.... look at the dowel pin pressed into the intake cam the rotates by the CMP,,, see if the nose of the dowet is ate up.deformed, if so, you will need to replace the intake cam, and if solid follower, adjust the valves via the shims on top of the followers...

P1166: Undefined
Ox B1S1 at limit, possible biased sensor... wait till other stuff is corrected

PO440: Evaporative Emission Control System
Generic EVAP system, could be anything, I like it when an are specific code is stored, cuts diag time..HI-SCAN helps here, as we can force an EVAP test to help with diag as we move along

UoDoo: Undefined
No value, disregard

PO711: Transmission Fluid Temp Sensor circuit performance
As posted for meaning, I would look at Current Data, see if TCM is actually seeing temp... yes, clear it and try again

P 2300: Undefined
No value, disregard

Please help......I know I should take it into the dealership, but I am so cash poor right now.....I work full time and go to school paying for it on my own and I just need some help......My brother is a dodge mechanic and says he can probably replace any part necessary just doesn't have the right scanner I guess to figure out this issue please help.
 
1 - 2 of 2 Posts
Top