Hyundai Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
i picked up a 2000 accent about a year ago knowing that it had a blown trans and had been sitting for about a year prior. i couldnt get it to run when i first got it, so i let my brothers try to work on it, but they never got around to it, so i have it again. i am getting nothing to work from the ecm. no fuel, no spark, no fuel pump. is the fuel pump pwm from the ecm because i dont see a return line? i checked all fuses, they are all good. i didnt have any power though at ecu fuses 2 and 3 under the hood, with the key in the run position. i ran a jumper wire to the fuel pump test, and i was getting a powerful spray from the fuel line at the fuel rail. however, when attempting to start, im not getting spark, i dont hear the fuel pump running, and i dont smell any gas from the tail pipe. it led me to believe the ecm was bad, but i ran a generic scan tool on it and it connected and showed no codes. so, now im here again trying to figure this out. i did some research a while ago to see if there was an immobilizer, but i never really got a good answer. please help

the cam sensor was also replaced, but with no luck
 

·
Registered
Joined
·
17,552 Posts
Check all fuses with DVOM for voltage on buth legs of the fuse.

Inspect the crank position sensor, if the PCM does not where crank is, it will shut off fuel so you cannot flood engine/catalyst.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
alrighty, will do. is there a spec on the resistance of the ckps, and is there a specified a/c voltage to come from it at cranking speed?
 

·
Registered
Joined
·
17,552 Posts
The ETM shows the CKP to be a pulse generator,, so it will make AC voltage.

We will typically use the Hi-Scan for it' scope function, and watch the sine wave to see if generator is indeed working.. I want to say you will look for something like 1.3V AC, But I could very well be wrong,,, don't have paper manual here, so rely on minimal HMA info from home..
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
alright, thanks. ill see what i come up with this weekend. so there isnt any anti-theft or immobilizer on these cars?
 

·
Registered
Joined
·
17,552 Posts

·
Registered
Joined
·
1 Posts
Where is the crank position sensor located?
Will it go bad if it gets wet?

My 2001 accent will not crank after getting some flood water in the engine bay and on the floorboard.

No spark at the plugs.

I used a meter to check voltage at the connector that plugs in to the ignition coil and all I got was 0.07 volts.
 
1 - 7 of 7 Posts
Top