Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, All!

New to the community - and naturally, I found this forum because of the problem described in the topic.

So, the issue started not too long ago, manifesting itself as no/rough start after gas fill-up, with some stalling for a short period afterwards.
Withing a three fill-ups, the CEL illuminated, and a PO441 code was set. As you all know, (and I found out) this is a common problem relating to a faulty PCSV.
I received the OEM replacement part yesterday (28910-22040), and went to get a look at what it was like to replace.

OOF.

Before I "hack" into this, I figured I'd take advantage of any expertise you all could offer and hopefully save myself some trouble.
Please advise - and THANKS IN ADVANCE!
 

·
Banned
Joined
·
7,036 Posts
Remove what you need to get in there and do it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
LOL, Bud.
That's what I figured.
On my way out now - will let you know how it goes, and if I discovered anything that might help anyone else.
Thanks, grcauto.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Okay. Easy Peasey.

Removed top stabilizer bar.
Removed Air box (everything that holds the air filter), associated electrical connection (MAF Sensor harness) and a vent hose that was attached.
Found purge valve solenoid assembly right behind and below throttle body (toward firewall L.F. area), and was able to pull it out, disconnect one the electrical connection and the two vacuum lines.
Installed new valve , reassembled.
Went right down to gas station, refueled, car fired right up.
Will update if any issues, but I think all is good.

My reason for posting this is that I Googled the heck out of this, and could not find a definitive description of how to do this on a 2005 Hyundai Tucson 2.7L V6 before trying it.
I was afraid that I would have to be pulling the intake, etc., to get to it.

I hope that this post helps someone else out.
Thanks!
 
1 - 4 of 4 Posts
Top