Hyundai Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey all

Partner had her cooling system flushed and refilled with Nylon coolant.

Drove the car home and coolant was boiling and frothing out of the overflow bottle.

Temp gauge never went over between quater and half the drive home, about 50km

I assume it is air trapt in the system but when I removed the cap and tried to bleed it just keeps on spitting air bubbles outs.

It's had a new thermostat, water pump, coolant temp sender and radiator.

Any help appreciated
 

·
Registered
Joined
·
1,188 Posts
Could be tragic, is it boiling or is it pressurised like head gasket leak or maybe EGR cooler failure? Pressure test it and see what happens if it holds pressure or drops indicating a breach somewhere. Any evidence of oil or exhaust residue in the tank / cooling system or water in the oil?

at what point did the problem start in relation to all these being done?
new thermostat, water pump, coolant temp sender and radiator. Or have these been done because you're trying to work it ourt and it';s still playing up.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
EGR Cooler has been welded up by previous owner, the car did sit for some time with just water in it, so potentially could be a blocked radiator.

Changed them as when it needed a timing belt just decided to change the pump. Changed thermostat and sensor to see if it made a difference.

Also done the dye test and came back negative for exhaust gasses in the coolant
 

·
Registered
Joined
·
1,188 Posts
Right, yes . I remember that image, quite amazing. Did it ever run right with the EGR blocked off on the water lines?
 

·
Registered
Joined
·
1,188 Posts
Plain water will eat the crap out of the head and anything else alloy. I've got some nice pictures of a very dead D4EA from Sonata someone tried to botch up.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Runs perfectly no engine lights, roughness etc. Just need to sort this issue out, it's odd that it isn't heating up or anything.

Pull up in the driveway and it's bubbling away.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
I am gonna take it somewhere tomorrow to get looked at, as quite frankly this car is doing my head in.
 

·
Registered
Joined
·
1,188 Posts
Yeah, nearly lost mine 2 weeks ago getting my alternator out and introducing a coolant leak myself.

Yes , but before you did all this work, was it running right , and not bubbling? Who repplaced all thos e bits/ Was the thermostat put in the correct way ie not upside down , just throwing random thoughts out there.

I've blocked of a heater line once on a Subaru due to core failure. Nearly cooked it, found out real quick it needed flow through the 2 lines, and I'm wondering if flow is needed through that egr cooler to have the system running correctly. This is why I'm asking. you obviously did not weld it, so was it running with no bubbles prior.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
Both hoses are at the same temperature, so thermostat is opening up, when it was flushed is was through the top hose and then reverse flush through the bottom
 

·
Registered
Joined
·
1,188 Posts
yeah, the money they want for a motor exceeds the price of a whole used Santa, I think we can thank the exporters to for driving it up here. I had to pay 2 grand just to get a D4EA
 
1 - 16 of 16 Posts
Top