Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 99 tiburon FX, and when I first get in and drive it sometimes and its cold it will totally bogg down on me and hesitate. Not sure what could be causing it because it doesnt happen all the time. Also curious on how to fix the jiggly noise in the back hatch.

Any help would be greatly appreciated.
 

·
Registered
Joined
·
422 Posts
When you go to take off, you said it bogs down, then does it gradually pick back up to normal throttling, acting basically like a delayed throttle response?

If it is doing this then I would tend to lean towards the MAP sensor.
Excels were bad for tis when they first wnt to Map sensor, from the Air Flow sensor.

Obviously you are not getting your MIL flashing on your cluster?

As for the boot hatch, you can udjust your stop rubbers and your stiker height.

You should be able to find a happy medium where your noise will be gone and your boot lid still sits level with your body work.
I would also apply some Dri-Lube or equivalent to your lock and striker assembly, just in case I may not be on the right track with the striker and rubber adjustment.
 

·
Registered
Joined
·
1,221 Posts
Originally posted by Tibbygirl@Nov 3 2004, 05:37 AM
I have a 99 tiburon FX, and when I first get in and drive it sometimes and its cold it will totally bogg down on me and hesitate.  Not sure what could be causing it because it doesnt happen all the time.  Also curious on how to fix the jiggly noise in the back hatch.

Any help would be greatly appreciated.
[snapback]2277[/snapback]​


Hi Tibbygirl!
New NGK sparkplugs & plug wires are always a good idea, but meanwhile, as you say the problem occurs when making cold starts, it`s possible condensation is accumulating overnight on your plug wires & causing arcing..........try spraying them with WD40 to prevent this.

Cheers,
Nick. :)
 

·
Registered
Joined
·
1,851 Posts
no, plug wires would cause jerks but not "totally bogg down".

I am with Dr Hundi, could be AFS or TPS.

Tibbygirl, does your car have a K&N air filter installed ???
 

·
Registered
Joined
·
24 Posts
Hey !
I have a 1999 Tiburon SE ... the thing about it bogging down when it first starts up happens in mine too .... its almost as if humidity has something to do with it... it only does it in first gear when i go after its been sittin for awhile ... after that its fine... its really weird... i thought it might have had something to do with the air intake after its been sittin ... but i just put a 500$ AEM cold air intake in it and it still does it ...
~Tibchic~
 
1 - 5 of 5 Posts
Top