Hyundai Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
After getting to about 1/4 tank, I fuel up and fill the tank but when I try to start the car, it cranks for a while and then finally starts. It will idle really low so I have to rev it until the engine starts getting gas at a steady pace.

Anyone know how to fix this?
 

·
Registered
Joined
·
8,118 Posts
Next time it does that see if flooring the gas pedal while cranking starts if up faster. If so then there is a ECU update for fueling issues. It gets too rich at times on start up.

Here's the latest ECM UPDATE – MIL ON DTC P0300-P0304, P0128, P0328, P0461 TSB 13-FL-012 which supersedes TSBs 10-FL-004 and 10-FL-011. There have been several of these over the years for the Accent.

My dealer wanted to chage me $150 to do this. I just said no as flooring it would start up mine and it only happened rarely. They were replacing an axle seal anyway and ended up doing it for free, which they should have done anyway.
 

·
Registered
Joined
·
14 Posts
This can be caused by the evap purge valve being stuck open but this usually comes with a check engine light also.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #6 (Edited)
Pushing the gas pedal all the way in (WOT) allows me to start the car, although it wants to turn off unless I push the gas pedal in and keep it over 1000rpm. Would that be due to the evap purge valve, or the ECU?
 

·
Registered
Joined
·
8,118 Posts
Could be a leaking fuel injector flooding a cylinder. But there have been several ECU updates to address problems like this.

A leaking purge valve would lean out the engine and flooring the gas I don't think would do much good.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #8
Well I guess I'm just gonna keep doing WOT every time I fill up. I just got this car and I'd rather not put money into it, at least until the CEL comes on. Thanks for your help!
 

·
Registered
Joined
·
27 Posts
Discussion Starter #9 (Edited)
I just wanted to update this thread for any forum members, or even Googlers, who might find this useful;

I kept having the same symptoms until finally my CEL came on with P0455 (small evap leak). I ordered a genuine OEM Purge Control Valve (part # 28910-26900) for only $30 off of eBay, installed it, cleared the CEL, then filled the tank from 1/4 tank until the gas pump stopped.

Previously, I would have had to hold the gas pedal at WOT, crank it, then the car would start up and would struggle to stay on.

After installing the Purge Control valve, it started up as any normal car would. I'm glad to have had this resolved. Thanks to all who contributed!
 

·
Registered
Joined
·
65 Posts
I recently started having the same problem with mine and I'm wondering how difficult the installation of the evap purge valve is?
 
1 - 10 of 10 Posts
Top