Hyundai Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello all, first time on the forum. My moms 05 Santa Fe with the 2.7 I believe randomly stalled on her at the light, when she went to start it, the flywheel/starter was not engaging.

I just put a new starter in (they didn’t have the pigtails to bench test it). After installing it, it’s doing the same thing it was doing before. I pulled the little access door off and turned the engine and the flex plate is attached and no bolts are missing. I even tried pulling the starter out some to see if it possibly needs shims, which I can feel it spinning. Below is a video of the outcome, this is after a new starter being installed.at this point I’m aiming towards the new starter being faulty or possibly a no spark issue? Any input would be appreciated!

 

·
Registered
Joined
·
12,119 Posts
at this point I’m aiming towards the new starter being faulty or possibly a no spark issue?
Starter fault or no spark?? That's two completely unrelated systems, so I'm guessing you don't have a clue what the fault is or how to diagnose it.

I'm not getting any sound on your video but it looks like the starter is actually cranking the engine over OK. If the engine is cranking but not starting you should check to see if there is spark at the plugs, and check to see if the fuel pump is being switched on DURING CRANK. I think there is a fuel pump check terminal on the engine bay fusebox (usually marked "F/P CHK" on the cover). To check that the pump is being switched on probe the check terminal with a voltmeter and monitor the voltage during crank. You should see about 10V if the ECU is switching the pump on.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
The type of sound it’s making is like a electric spinning sound if that helps at all, it’s not turning over at all but when I turn the key instead of turning over it just makes that electric motor sound. I’ll check out the fuel pump tomorrow.
 

·
Registered
Joined
·
5,218 Posts
The starter is engaging with the ring gear on the flex plate and is spinning at a fair speed for cranking. Do you have compression? I'm thinking there's more to the story than "randomly stalled on her at the light,.."
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
It was starting to lose power a couple days before doing it, felt like the parking brake was engaged. When it did that, it didn’t matter if the gas pedal was to the floor it would crawl. Only did it as soon as it started warming up
 

·
Registered
Joined
·
3,915 Posts
Stalled?
Engine is spinning at a very goo d speed?
But the sound is not quite right?
Does not start?

Does this sound like a broken timing belt?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
This is what I’m aiming for, I’ve never had a vehicle with a timing issue nor have I ever heard that noise before in my life!
 

·
Registered
Joined
·
12,119 Posts
I've worked on a few car with snapped timing belts but I've never heard one that sounds quite like that before.
Regardless, the only way to know if it's a timing issue or not is to remove the belt covers and take a look.

When was the belt last replaced?
 

·
Registered
Joined
·
3,915 Posts
Well, listening to that whining sound, it made me think that the pinion gear isn't engaging properly
So maybe replacing the starter ... you got the wrong starter
It has been known to happen .. that the wrong starter was put into the wrong box
 
1 - 11 of 11 Posts
Top