Hyundai Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
04 SF, 3.5L v6, 83K mi. Have had vehicle for about a month, clean CarFax.

Over the past couple weeks, every few days the SF will shake and shudder a lot under acceleration, engine appears to run rough. Engine seems to run smooth once your moving, but stop at a light and it'll shake and shudder again till you get up to speed. Get to destination and it will have cleared up or when I go to drive it again it's fine and runs fine for another couple days. Then it'll do it again, once, then fine again. No check engine light, gas mileage hasn't been affected (still 27mpg highway).

Sensor? Tune up?

Sam
 

·
Registered
Joined
·
32 Posts
It may be the fuel. I assume that for the first few weeks of the month there were no issues. Did you recently either add fuel or are you possibly at less that 1/4 of a tank? It's possible that you have some water in the bottom of your tank. Try filling up at a station you are familiar with and add a can of dry gas and see if the problem persists.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
QUOTE (nevis111 @ Jul 5 2010, 04:42 PM) index.php?act=findpost&pid=339036
It may be the fuel. I assume that for the first few weeks of the month there were no issues. Did you recently either add fuel or are you possibly at less that 1/4 of a tank? It's possible that you have some water in the bottom of your tank. Try filling up at a station you are familiar with and add a can of dry gas and see if the problem persists.
Yeah the problem just showed up about 10 days ago. Didn't get to see your reply before we left yesterday for a ride to our daughter's place about 70 miles. SF ran fine. Went to go home last night and got the shuddering/shaking under acceleration for about 2/3 of the way. Then it just disappeared and ran fine.

Read your reply this morning. SF had shuddering, put in bottle of dry gas and filled up, ran fine all the to work and then fine back home. We'll see how it fares over the next couple days.

Sam
 

·
Registered
Joined
·
17,552 Posts
Platinum plugs due at 60, best to change wires, be aware of white/grey burn mark on each ignition coil body...

MIL flashing ?

MIL illuminated ?

Should be a linear throttle program available, and an ox sensor logic program too..
 
1 - 4 of 4 Posts
Top