Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
What's up guys and girls. My name is Dylan. I live in nj and have a 2004 Hyundai Santa fe 2.7 . Recently I let my mother bbb morrow my car and she told me it started funny . It only did this for about a day when I got told the battery was dead . How ever I brought the brand new battery out of my Nissan with and changed it out . Tried cranking it I got nothing only thing that helped was all the needles on the instrument panel maxed out and then went back down and I got a little click . Checked the fuses nothing wrong there. . So next I went an took off the shield over the starter and when doing so it sarked at me . So for sure i thought this was the issue . New battery check new starter check . Went to fire her up this time it cranked over fine but wouldn't start . . . I checked the alternator but ruled it out as it checked out fine with my multi meter besides that it was brand new bought just 2 months ago .

So I went from having a no crank no start. To changing the starter only to have it crank now but still not start . Fuses seem fine . I do hear the fuel pump priming at least it sounds like it is . I also tried to start it in neutral to see if anything would happen thinking maybe it was the neutral safety switch but it made a some weird noise and wouldn't start . How ever I also ruled this out because I also ruled that out for because I read that the sensor should make a noise since it moves an that the car being in neutral it still wouldn't start witch is what happend. How ever I don't know if this rule applies for automatics witch is what my Santa. Fe is . Please help anybody have any issues like this before ?
 

·
Registered
2007 Honda CRV
Joined
·
4,582 Posts
Tough reading the opening post

Anyway, I would suggest cleaning All electrical contacts/terminals
Clean the battery terminals and don't forget the grounding straps (both the battery and engine)

Good luck
 

·
Registered
Joined
·
17,552 Posts
Cant check alternator with a crank - no fire condition,, the engine not running to make charge voltage for yo u to inspect..

2.7L ,,, Hmmm,, crank and no fire,,, did we scan the thing yet ?? How did we "check" fuses ?? DVOM is your friend..

Back to the 2.7L,,, I be interested in what the crank position sensor pigtail look like.. that part been a maintanance item anymore.. reach up in and roll pigtail tube right at and the sensor body and slight away between fore finger and thumb, looking for cracks / crumbling of outer sleeve,, if it crack - broken - crumbled,, replace it like last week, and re-inspect fuses with DVOM at both leg of fuse.. shorted CKP pigtail take out 1 of couple ECU fuse in the engine room box,, and shut down part of the PCM
 
1 - 3 of 3 Posts
Top