Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Started happening randomly yesterday. The door was locked (I'm not sure how it got locked), I unlocked it with the key, and as soon as I opened the door, the alarm started going crazy.

I believe it is an aftermarket alarm, because it wasn't just the horn that was going off, but a much louder alarm noise. There is also some sort of sensor/antenna thing on the inside of the windshield that says "hx" on it. No clue what it is, since I bought the car used.

I ended up disconnecting the battery to make the car shut up. I tried the whole reconnect the battery, turn the key to on, and wait 30 seconds thing, but that didn't do anything. The alarm randomly stopped, then started again after ~10 seconds.

Possible variables: the hood was open when I unlocked the door initially, I had the key w/remote in my pocket, doors may have been locked from the interior (honestly no clue how they got locked).

What can I try next?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Found a Avital Avistart 4100 under the dash. Disconnected that, plugged the 1 plug from that back into the ignition.

Now the alarm isn't going off, but I have a new problem. When I try to start the car, it won't start, but it will keep trying to turn over until I turn the key to the off position. Like if i let go of the key from the start position, it will keep trying to start until I turn the key off.
 

·
Registered
Joined
·
1,733 Posts
Also, be sure the battery is good, and all grounds are clean and tight. Had an '06 without aftermarket alarm do the exact thing you describe. Turned out to be a bad battery cable clamp. The voltage drop across the bad connection drove the factory anti-theft system crazy.
 
1 - 4 of 4 Posts
Top