Hyundai Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. MD (2011-2016) Elantra sedan/coupe
    My 2015 elantra 72,000 miles will quite often get a real rough idle and stalls if you stop and then won’t start back. It will crank but sounds like it is getting no spark at all. Then after about 5 minutes it will start up as if nothing happened and it will run fine. No matter how far I keep...
  2. MD (2011-2016) Elantra sedan/coupe
    I have a 2012 Hyundai Elantra sedan Limited with the push button start and 1.8L, about 170k. Since I've had the car (about 6 years), it's always had a mysterious and intermittent hard start where you push the start button and it will turn over while sputtering and it'll finally come to life and...
  3. MD (2011-2016) Elantra sedan/coupe
    Hey everyone, at a little bit of a loss here. I have a base model 2015 Hyundai Elantra. My engine was throwing codes and symptoms of a bad map sensor. Rough idle, losing power while driving, misfiring, running to rich/lean. I order a MAP Sensor cheap off of Amazon, threw it in, it worked but...
  4. LC (2000-2005) Accent
    Hi I need some help. My 04 accent 1.6 runs rough and rpm drops at stops when warmed up. When cold all is good. I have new coils new plugs new wires new coolant temp sensor new iac new map new intake gasket. Was leaking. New camshaft sensor. New torque converter it was locking up. New...
  5. CM (2007-2012) Santa Fe
    So I have a 2008 Santa Fe 2.7 that recently had the battery and alternator replaced. Shortly after I got it back the car would lunge when I put it in drive (and I think reverse, if I recall). The sensation was as if I were pushing on the gas and the brake at the same time and then letting off...
  6. TG (2006-2011) Azera
    Hi folks, I have a 2006 Hyundai Azera with 76k km and I've started having a weird issue about two weeks ago. When I start the car, it would idle pretty high for a couple minutes and would have a lot of white smoke coming from the exhaust. When I put the car in drive, it sounds like diesel...
  7. Venue
    I have a 5 week old Venue (auto) and when starting in the morning, it idles slightly rough, just for about 15 seconds, then it's OK. This has occurred the last 3 mornings. The weather is not cold, about 22C (72F). It only happens first thing in the morning. My thought is that it is not fuel as...
  8. MC (2006-2011) Accent
    Hey everyone! I should've checked this forum a while ago, but I'm looking for some help with my 2007 Accent GS hatchback. It was having trouble starting after I got gas, so I bought some fuel injector cleaner and that seemed to fix it. Used it monthly. Well, during quarantine I haven't been...
1-8 of 8 Results
Top