Hyundai Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. SM (2001-2006) Santa Fe
    Hola, buen dia, quisiera que me ayudarán a saber, por que?, mi hyundai, esta tirando liquido de anticongelante por este orificio alguien tiene alguna idea, les agradecería mucho su conocimiento
  2. LM (2010-2015) Tucson/IX35
    Summary of issue on bottom of post: Late 2021 I decided to finance my first vehicle and choose to go with a 2014 Hyundai Tucson FWD, 6 speed. I got it at a decent price and it has most of the features I was looking for. However after I had gotten it home and drove about 200km I noticed a pretty...
  3. TL (2016-2021) Tucson/IX35
    So my friend's 2018 2.0 awd has a leak starting on the rear of the oil pan, I noticed it the other day when I was doing her front brakes. The car has only 63k on it so it's kinda pathetic that it's starting to leak like that on only a three year old car with low miles. The problem is the...
  4. i40 Forum
    Hyundai Diesel Estate, i40 Premium Crdi Auto, 2012, 1685cc (WITH SUNROOF) I have an issue with water ingress on passenger side, behind dash on the left side, leaking into the footwell and reaching all the way to rear seat footwell. The carpet was completely wet and had to take the seat out...
  5. NF (2006-2010) Sonata
    I have a 2006 GLS V6 with relatively low miles. About an inch behind the back of the battery and maybe 3 inches below the bottom of the battery I see some fluid pooling. It looks sort of watery or thin. When I use a paper towel to absorb it, the fluid is dark black in color. Looks like engine...
  6. TL (2016-2021) Tucson/IX35
    I was servicing my Tucson (2016 Limited AWD) when I noticed I had residue between the transaxle bellhousing and the engine, taking the inspection plate off seems to show that the engine side is dry and clean, so I'm suspecting that it could be the input shaft seal(s) on the DCT. Residue doesn't...
  7. Grandeur & XG Forum
    Ive had the radiator, and water pump replaced about 30-40k miles ago. Everything up top looks clean, with zero visible signs (or smells) of any leaking. But it seems like I have a slow leak, almost right next to the passenger side tire. Given how cramped everything is, and my lack of knowledge...
1-7 of 7 Results
Top