Hyundai Forums banner

ix35

  1. Tucson/IX35 LM Models
    Ok hi guys I'm struggling here trying to solve this. So 2011 ix35 1.7 diesel. Built in sat nav has worked fine since I have owned the car but for around a month now it's showing that the car is sat on our drive no matter where we are. So common sense approach (I hope) was to remove fuses for...
  2. UK
    Hi all. I have a Hyundai IX35 premium. I have an original GPS head unit. Unfortunately, it got damaged when one of my kids forced a CD into the player when there was already in there a damaged the mechanism. I have tried to fix it by removing the unit, manually removing the discs, and manually...
  3. Other Hyundai Models
    Hi all, First post here. I'm switching out the standard radio from my 2010 ix35 crdi for this Sony unit. Given the new unit utilises DAB, and I may as well replace the standard aerial to use that....does anyone have experience of running new cables on this model and can offer pointers? How...
  4. 2016- Tucson/IX35 Models
    Hello everyone! I Hope somebody would please help me, I´m having this trouble with my tucson, when i´m driving for a while usually for rides longer than 1 hour, it enters limp mode without any MIL and I have to stop, leave it off for a minute and restart to get ride of it, i´ve connected the...
  5. Tucson/IX35 LM Models
    Hello, I have a 2012 IX35 Highlander. I have my phone connected via Bluetooth but when I call people they can barely hear me. No idea where the microphone is if there is one and not sure how to fix this issue as it is very frustrating as I need to use the phone on the road for my job. Any tips...
  6. 2016- Tucson/IX35 Models
    Hi everybody. Hope I don't sound like an idiot whilst trying to make sense of the problem I have. I'm just repeating what my mechanic has told me. I have limited knowledge of engines. My ix35 2litre premium 4WD 61 plate, broke down 4 weeks ago. I had it towed to the nearest garage...
  7. Tucson/IX35 LM Models
    I have an ix35 2015 and the sound has gone completely. Had been going on and off for a while. I used to just turn the power on and off and it fixed it. However, now there is no sounds at all. Any suggestions?
  8. Tucson/IX35 LM Models
    I recently noticed that my headlight washers are not spraying on my ix35. Checked the 30A fuse, Its fine. Pulled the relay and tested it. Seems to be fine. Swapped the relay for another 35A one. Still nothing. Checked for voltage across the relay sockets in the fuse box and got 9.5v on the coil...
  9. Tucson/IX35 LM Models
    Hey Folks, I have recently purchased a used IX35 from a Hyundai Dealership with 40K miles on the clock. On the test drive, the vehicle was rifting to the left which the dealer stated they would correct with wheel alignment. On collecting the vehicle, the issue remains even after wheel...
  10. Tucson/IX35 LM Models
    Hi, If this has already been discussed please point me in the right direction.... (I couldnt find an answer) My 2013 IX35 needed back tyres and I had a new pair at home so I had them fitted. The problem is is that the tyres are a slightly different size (the originals were 225/55/18 and the...
Top