Hyundai Forums banner

crankshaft position sensor

  1. HD (2006-2010) Elantra
    Hi, having a hard time finding where the Crankshaft Position sensor location is on our 2009 Elantra. This is for the P0016 Code. Can anyone point or provide a diagram or pic or video? So much appreciated. This is the last code I have to fix :)
  2. MD (2011-2016) Elantra sedan/coupe
    Hello everyone. I have a little post repair issue I'm hoping somebody can help me with. I just replaced a crankshaft position sensor (genuine hyundai part, not aftermarket) in my 2015 Elantra 1.8 liter. Since the replacement my car bucks hard when shifting from first gear to second. Before...
  3. CM (2007-2012) Santa Fe
    Hello. I have a 2010/2011 3.5 V6 AWD Santa Fe. It has 50.000 miles on it. I'd really appreciate if you guys would help me figure this one out. Once this is solved, I'll post the solution here. The car stalled as I got off the freeway at about 20 MPH. It was running seemingly fine, even though...
  4. CM (2007-2012) Santa Fe
    Hello everyone, I have a 2012 Santa Fe 2.4 MPI with 112k. This vehicle has been a reliable vehicle since new. A few weeks ago the vehicle started to have a knock at idle and I found metal in the oil. After calling Hyundai and finding out that the 2.4l MPI motors are covered like the 2.4 GDI...
  5. Santa Fe Diesel Models
    hey guys New to the forum. I've been told my crankshaft position sensor is faulty and needs to be replaced. I've been trying to replace it but I can't find it at all. Can someone guide me in the right direction. Cheers
  6. Getz Forum
    Hi, I recently bought a 2003 1.1l Getz with progressively worse starting problem.. I check the air filter, the sparks, clean the injectors, the idle valve, the map/iat sensor, replaced the spark plugs, and finally yesterday also the fuel filter; but continues not to start. So, I removed one...
  7. SM (2001-2006) Santa Fe
    I meticulously followed instructions for replacement of the timing belt, water pump, and crankshaft position sensor. I purchased the vehicle knowing that there was an issue. It would start and run very rough and unable to get over 35 mph. The codes said it was the crankshaft position sensor, So...
Top