The wiper fluid pump stopped working on my 99 Elantra. - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-15-2019, 01:22 PM Thread Starter
Junior Member
 
Join Date: Nov 2017
Posts: 7
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
RPK99Elantra is an unknown quantity at this point
(Thread Starter)
The wiper fluid pump stopped working on my 99 Elantra.

The wiper fluid pump stopped working on my 99 Elantra any suggestions on where to start to resolve and fix it. Is there a fuse for it? a relay? Any help will be greatly appreciated.
RPK99Elantra is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-15-2019, 05:32 PM
Senior Member
 
AUTOSPARK's Avatar
 
Join Date: Nov 2014
Location: Scotland, UK.
Drives : Nissan NV200 Flies : Rans S6ES
Posts: 11,049
Mentioned: 113 Post(s)
Quoted: 2335 Post(s)
AUTOSPARK is an unknown quantity at this point
The washer pump usually shares the same fuse as the wiper motor, so if the wiper motor is still working the fuse must be OK.
There isn't a relay for the pump.

Probably the easiest way to diagnose the problem is to disconnect the pump harness connector and connect a voltmeter or a 12V bulb across the two terminals of the connector. Have someone operate the switch (ignition on) and see if you get 12V/bulb lights. If so the pump has failed and will need replaced.
AUTOSPARK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome