Brake Switch Failure - Page 6 - Hyundai Forums : Hyundai Forum
Reply
 
LinkBack Thread Tools
#51 Old 07-07-2012, 04:25 PM
Hyundai-Forums.com Vendor
 
AccentGlowLED's Avatar
 
Join Date: May 2010
Location: USA
Hyundai
Posts: 314
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AccentGlowLED is an unknown quantity at this point
(Thread Starter)
Quote:
Originally Posted by louky View Post
i still haven't gone to the dealer about it, i just keep trying. putting the FOB in the port, taking it out, then it eventually starts. i thought it was suppose to start immediately when you put the fob in the port and push start, but it doesn't. just keeps saying press brake pedal. it's happening more and more often now so i need to take it in before i get stranded.

i read on here about the 30 second thing, but it doesn't work. i hold the button down forever and it still doesn't start. what's the trick?
Even with the fob, the car still wants to see the brakes pressed to start.

The way to start when you have a brake switch failure: Nothing on, enter car and push button once (or after it won't start, turn everything back to off and start over) after the first press, THEN press and hold a second time and the car should start after about 10-15 seconds
AccentGlowLED is offline  
Sponsored Links
Advertisement
 
#52 Old 07-07-2012, 05:28 PM
Senior Member
 
SonataSE88's Avatar
 
Join Date: May 2011
Location: Los Angeles
Drives 2011 Hyundai Sonata SE
Posts: 411
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
SonataSE88 is an unknown quantity at this point
Garage
Yea what iceberg said does work..press the button to turn on radio and then press and hold it till for ten seconds or more and then it does turn on. I tired it this morning and it works. Also go to the dealer ship...mine is current replacing it even though it's an intermittent problem. Glad my dealership rocks lol

Sent from my SGH-T989 using AutoGuide.Com Free App

2011 Hyundai Sonata 2.4 (207 HP)
Radiant Silver SE (Shane Edition, lol)

Link to My Garage
SonataSE88 is offline  
#53 Old 07-07-2012, 06:02 PM
Senior Member
 
13SonataScott's Avatar
 
Join Date: Aug 2010
Location: Central California
2013 YF 2.0T Limited P. & Optima SE V6
Posts: 2,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
13SonataScott is an unknown quantity at this point
Yesterday my traction control system light came on while stopped at a red light. I was near the dealership so I stopped by. The service manager greeted me and asked how things were going... I told him, he said sounds like a brake switch failure. A mechanic read the code it had generated, it said the same thing, so it was replaced right then and there. The car wasn't even in a mechanics bay, still in the drop off area. The paperwork took longer than the repair. 36 minutes from when the light came on until I left the dealership with my warrantied repair. I can't complain about that! Btw, 47536 miles.
13SonataScott is offline  
#54 Old 07-08-2012, 01:54 AM
Member
 
Join Date: May 2012
Location: Louisiana
Drives Sonata 2.4 SE
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
whitebean88 is an unknown quantity at this point
yea i had the same problem with my Brake switch too. i had to kick the pedal for it to work. about a month later the push button wouldn't work. i had to get that replaced too. there was a short in the circuit.
whitebean88 is offline  
#55 Old 01-02-2013, 11:31 AM
Senior Member
 
Join Date: Sep 2008
Posts: 161
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
fragile is an unknown quantity at this point
I am just starting to notice intermittent failures to start, saying the brake pedal is not being pressed. I have about 22,000 miles on my 2011 Limited. I have tried the procedure for holding in the start button for 15-20 seconds and that works so at least I have a backup plan to start but will be taking it to the dealer soon.
fragile is offline  
#56 Old 01-02-2013, 12:08 PM
Senior Member
 
Join Date: Jan 2011
Location: South Florida
2011 Sonata SE 2.0T
Posts: 445
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
rscottbau
Holding the start button for as long as a minute didn't work for my 2011 SE Turbo when my brake switch failed. Glad it works for you.

Ron
rscottbau is offline  
#57 Old 01-02-2013, 03:28 PM
Member
 
Join Date: Mar 2010
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
WarmFZI
Don't forget that when your brake light switch is failing, there will be times that when put on the brakes, your brake lights will not come on. This puts you at additional risk of being rear-ended.
WarmFZI is offline  
#58 Old 01-02-2013, 03:44 PM
Senior Member
 
Bearcats's Avatar
 
Join Date: Jun 2010
Location: Over Here
'13 Ford Fusion Titanium '11 Sonata YF 2.4 Limited (Wifes)
Posts: 3,347
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Bearcats is an unknown quantity at this point
Quote:
Originally Posted by 11SonataScott View Post
Yesterday my traction control system light came on while stopped at a red light. I was near the dealership so I stopped by. The service manager greeted me and asked how things were going... I told him, he said sounds like a brake switch failure. A mechanic read the code it had generated, it said the same thing, so it was replaced right then and there. The car wasn't even in a mechanics bay, still in the drop off area. The paperwork took longer than the repair. 36 minutes from when the light came on until I left the dealership with my warrantied repair. I can't complain about that! Btw, 47536 miles.
You have a fanTAStic service bay. Better go buy those guys some pizza!

KDM YF LED tails | Llumar 30% Ceramic Tint | V-LED 5K Interior lighting | XenonSupply 4300K Slimline HID's | The "cup" mod
Bearcats is offline  
#59 Old 01-08-2013, 12:44 AM
Junior Member
 
Join Date: Jan 2013
Location: Papillion, Ne
2011 Sonata YF
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Combatmedic is an unknown quantity at this point
Is this seeming to be a push button start only issue? Should I be worried with my '11 GLS with 34k on it?

I feel like I am diagonally parked in a parallel universe!

2011 YF, 6K HIDs, 6K switchback LEDs turn signals, Much more to come!

Combatmedic is offline  
#60 Old 01-08-2013, 01:37 AM
Senior Member
 
jdugan4859's Avatar
 
Join Date: Jun 2010
Posts: 505
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jdugan4859 is an unknown quantity at this point
Quote:
Originally Posted by rscottbau View Post
Holding the start button for as long as a minute didn't work for my 2011 SE Turbo when my brake switch failed. Glad it works for you.

You have to press it once while everything is off, this will bring on the accessory's, then hold it down.
jdugan4859 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome