Throttle And Idle Sensor Problem - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
#1 Old 11-14-2005, 02:31 AM
Junior Member
 
Join Date: Jan 2005
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
SuperAman
(Thread Starter)
So I went into the dealer and got them to check out my car cause of the "CEL" and the idling erratically problem. They spent a hour and half and came back and told me it's the "throttle sensor and idle sensor" that was screwed. Is this common with the sonata 2.5 v6 1999 model? With the symptons could that really be it? oh they said most likely the throttle sensor was degraded by bad gas over time...true?false?
I've had a timing belt change, fuel injection cleaning and spark plugs changed already.
Any do it yourself type thing for this prob? When stopped at a light, rpm's idle about 1000 and then it dips down and up, down and up. Seems like it loses power/stalls and then unstalls. When I gas it after, it shutters a bit and goes

any help is appreciated
SuperAman is offline  
Sponsored Links
Advertisement
 
#2 Old 11-14-2005, 06:22 AM
MODERATOR
 
trajetXG's Avatar
 
Join Date: Aug 2004
Location: Singapore
Drives: A 2008-7 Seaters Santa Fe CM
Posts: 7,404
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
trajetXG is an unknown quantity at this point
Try checking if there's any vacuum leaks...look at the PCV system.


Hyundai...Drive your way.
trajetXG is offline  
#3 Old 11-14-2005, 02:33 PM
ADMINISTRATOR
 
Montego's Avatar
 
Join Date: Jan 2005
Location: South East England
Drives 2 XG's (2001 & 2002) & Ford Escort Van
Posts: 12,625
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Montego has disabled reputation
Garage
this is a classic sighn of a faulty TPS valve (throttle position sensor) and it is not uncommon



MONTEGO

""""""""""""""""""""""""



Montego is offline  
#4 Old 11-16-2005, 06:31 PM
Junior Member
 
Join Date: Jan 2005
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
SuperAman
(Thread Starter)
well I found my recipet and the codes that they pulled out of the ecu was
P0500, P0507

ANy idea about what this are? some kinda sensor right,, throttle?

SuperAman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome