2001 Automatic Transmission Shifting Erratically - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
#1 Old 05-14-2011, 01:02 AM
Junior Member
 
Join Date: Apr 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ghetto3jon
(Thread Starter)
i have a 2001 elantra with 136k. the automatic transmission (which otherwise shifts very smoothly and shows no sign of problems) shifts suddenly and erratically when i'm driving at a constant speed. i'll be traveling along (speed doesn't matter), and it will suddenly downshift, then upshift, then downshift, etc. this started off being very occasional, but now it randomly shifts every 5-10 seconds.

i've changed and checked the fluid, and tried replacing the Input Speed Sensor and the Output Speed sensor...that didn't fix it. it also does not blow a check engine code. i'm convinced there must be a sensor somewhere that is faulty. it really seems as though the transmission is electronically confused.

any help is greatly appreciated.
ghetto3jon is offline  
Sponsored Links
Advertisement
 
#2 Old 05-14-2011, 04:43 AM
Senior Member
 
jsinton's Avatar
 
Join Date: Jun 2009
Location: Inverness, Florida
'99 Elantra Wagon '03 Kia Sedona
Posts: 4,388
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
jsinton is an unknown quantity at this point
Did you scan for codes? I would only be speculating to say that the range selector switch can do weird things when it goes bad.

jsinton is offline  
#3 Old 05-14-2011, 10:18 AM
Senior Member
 
sbr711's Avatar
 
Join Date: Apr 2010
Location: hiding from those who might be looking for me
I dont own Hyundai car, I drive everybody else Hyundai during day
Posts: 8,911
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
sbr711 is an unknown quantity at this point
You need to access the TCM and see if any codes hiding in there.

<--- please fill in the 'location' and 'what you drive' boxes on your personal profile page.
This information makes it much easier for other members to answer/comment on your posts.
sbr711 is offline  
#4 Old 05-14-2011, 11:44 AM
Junior Member
 
Join Date: Apr 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ghetto3jon
(Thread Starter)
so take it to the dealer, basically. bummer.
ghetto3jon is offline  
#5 Old 05-14-2011, 11:47 AM
Junior Member
 
Join Date: Apr 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ghetto3jon
(Thread Starter)
although maybe i'll try the range selector switch first if it's cheap. do you have a part number? i'm unfamiliar with that part. thanks so much!
ghetto3jon is offline  
#6 Old 05-14-2011, 01:24 PM
Junior Member
 
Join Date: Apr 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jfb777
QUOTE (ghetto3jon @ May 14 2011, 01:02 AM)
Quote:
i have a 2001 elantra with 136k. the automatic transmission (which otherwise shifts very smoothly and shows no sign of problems) shifts suddenly and erratically when i'm driving at a constant speed. i'll be traveling along (speed doesn't matter), and it will suddenly downshift, then upshift, then downshift, etc. this started off being very occasional, but now it randomly shifts every 5-10 seconds.

i've changed and checked the fluid, and tried replacing the Input Speed Sensor and the Output Speed sensor...that didn't fix it. it also does not blow a check engine code. i'm convinced there must be a sensor somewhere that is faulty. it really seems as though the transmission is electronically confused.

any help is greatly appreciated.

sounds like the transmission range sensor to me i had the same problem and it turned out it was that replaced it and it got a lot better and i did the speed sensors as well mine still does the erratic shifting here and there but i havent had the chance to adjust the transmission switch yet be sure to when u change out the sensors to get the codes wiped then drive 50 miles then check for codes again..
jfb777 is offline  
#7 Old 07-20-2012, 10:44 AM
Junior Member
 
Join Date: Jul 2012
Location: 15102
hyundai elantra 01
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
danielson3 is an unknown quantity at this point
Have an 01 elantra had the same problem.replaced the TPS throttle position sensor.completely fixed the problem.
danielson3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome