2003 Elantra Transmission Problems - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
#1 Old 04-23-2010, 08:12 AM
Junior Member
 
Join Date: Apr 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
lurch75
(Thread Starter)
My wife has a 2003 elantra that has developed a strange problem. When selecting reverse (automatic) their is a noticable delay(3 sec appox ) before it engages. Then if i select drive when it is the is a hash engament and it seems to go straight into overdrive. The only way to stop this is after the transmission is warm turn the car off and restart it. When thtrans mission is warm there is no problem except only a slight delay when reverse is selected. Took it to a transmision guy and he said it might be the cmputer. Any suggestions from the forum ?

Thanks Paul
lurch75 is offline  
Sponsored Links
Advertisement
 
#2 Old 04-23-2010, 09:40 AM
Senior Member
 
jsinton's Avatar
 
Join Date: Jun 2009
Location: Inverness, Florida
'99 Elantra Wagon '03 Kia Sedona
Posts: 4,370
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
jsinton is an unknown quantity at this point
Did you change the fluid? Doesn't sound like the computer. Is there a check engine light?


jsinton is offline  
#3 Old 04-24-2010, 12:08 AM
Junior Member
 
Join Date: Apr 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
lurch75
(Thread Starter)
QUOTE (jsinton @ Apr 23 2010, 08:40 AM)
Quote:
Did you change the fluid? Doesn't sound like the computer. Is there a check engine light?
Yes the fluid has been changed and no there is no check engine light on. The place i took it to said he disconnected the wiring harness to the transmission and the delay was gone. He said he put the computer on a diagonistic machine and it was giving or recieveing strange signals.
lurch75 is offline  
#4 Old 05-03-2010, 07:17 PM
Senior Member
 
sbr711's Avatar
 
Join Date: Apr 2010
Location: hiding from those who might be looking for me
I dont own Hyundai car, I drive everybody else Hyundai during day
Posts: 8,788
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
sbr711 is an unknown quantity at this point
MIL ??

Input or output speed sensor will make TCM start A/T in 2 or 3....

Scan the TCM and PCM for DTC

<--- please fill in the 'location' and 'what you drive' boxes on your personal profile page.
This information makes it much easier for other members to answer/comment on your posts.
sbr711 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome