Trouble Codes: U0d00, P0711, P2300 - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
#1 Old 11-22-2009, 09:19 PM
Junior Member
 
Join Date: Nov 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mubai
(Thread Starter)
Hi all,
I'm new to the Hyundai forum, but not new to car forums. Anyway, I was hoping someone could help me diagnose the following codes: U0D00, P0711, P2300.

U0D00 - I have no idea what this means.
P0711 - Transmission Fluid Temperature Sensor "A" Circuit Range/Performance. How would I go about fixing this?
P2300 - Ignition Coil "A" Primary Control Circuit Low

Any help would be greatly appreciated.
mubai is offline  
Sponsored Links
Advertisement
 
#2 Old 04-26-2010, 04:39 PM
Junior Member
 
Join Date: Jul 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
godsantagonist
any updates on these codes?

i have the same exact 3 codes: U0D00, P0711 (pending), P2300 (pending) on my 2000 hyundai sonata gls. i've read that the U0D00 might be related to the MAF and am going to try and clean it first to see if that helps. the codes do trip the cel, but it comes and goes.

i also have sluggish, jerkiness when accelerating at times. perhaps related to the transmission and the pending P0711 code.
godsantagonist is offline  
#3 Old 04-27-2010, 08:31 AM
senior member
 
wymi's Avatar
 
Join Date: May 2007
Location: Chicago, Illinois
Drives: Hyundai & KIA
Posts: 3,783
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
wymi is an unknown quantity at this point
The U0D00 code does seem to come up as an MAF related problem in my search. Check connector and wire harness leading to the MAF if you replaced or cleaned the MAF and the problem is still present.

wymi is offline  
#4 Old 05-13-2010, 02:02 AM
Junior Member
 
Join Date: Jul 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
godsantagonist
[b]****update****

sorry so late but i had to change the battery too...

i cleaned the air intake at the butterfly as posted here on this site. also, i cleaned the maf sensor with maf sensor cleaner. i erased the codes after i put everything back together after drying. i have driven about 150 miles since the cleaning and the codes have not returned.


i hope this helps out others and thanks wymi for the response and suggestions.
godsantagonist is offline  
#5 Old 07-23-2014, 07:44 AM
Junior Member
 
Join Date: Jul 2014
Location: Elgin/IL/US
Drives 2001 Sante Fe
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Traecool is an unknown quantity at this point
I had code u0d00 on my 2001 Santa Fe. Reseated gas cap, restarted SUV twice and check light cleared. May need to drive a bit to build pressure.
Traecool is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome