terryman - Page 2 - Hyundai Forums : Hyundai Forum
Reply
 
LinkBack Thread Tools
#11 Old 01-16-2013, 05:34 PM
Junior Member
 
Join Date: Jan 2013
Location: ireland
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
markdo is an unknown quantity at this point
hi all.. i am having a simular problem
if the glow plug light comes on in the dash the terre will start and if not you could crank it till the grave
in saying that it only comes on for about 1 sec .( temp is usually around 3c)
my first thought was the relays
then temp sensors
so after reading this its down to temp sen
can you tell me the location of these
markdo is offline  
Sponsored Links
Advertisement
 
#12 Old 01-16-2013, 05:41 PM
senior member
 
Em-squared's Avatar
 
Join Date: Aug 2011
Location: near Portland, OR
Posts: 6,837
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Em-squared is an unknown quantity at this point
Garage
markdo.

Fashionista.



Former driver of 2011 Elantra Limited no tech, and 2010 Genesis Coupe 3.8 Track
Em-squared is offline  
#13 Old 01-17-2013, 09:35 AM
MODERATOR
 
RBURGOSS's Avatar
 
Join Date: Aug 2009
Location: Costa Rica
Posts: 1,462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RBURGOSS is an unknown quantity at this point
Quote:
Originally Posted by markdo View Post
hi all.. i am having a simular problem
if the glow plug light comes on in the dash the terre will start and if not you could crank it till the grave
in saying that it only comes on for about 1 sec .( temp is usually around 3c)
my first thought was the relays
then temp sensors
so after reading this its down to temp sen
can you tell me the location of these

The attached service manual pages show where are all the sensors for the 2.9 crdi engine (terracan)

For the ECT (engine coolant temp) sensor, look at second page. The main engine drawing has mistakenly indicated that this sensor is located at the intake manifold, where the glow plugs are. It is located at the thermostat housing intake towards the front of the engine, as showed on Drawing 1, page FLB 24.

Let us know your findings.
Attached Files
File Type: pdf TERRACAN 2.9 ENGINE SENSORS.pdf (240.8 KB, 23 views)

Robert B.

Don't forget to participate and vote in the February 2013 ROTM thread at http://www.hyundai-forums.com/249-ri...2013-rotm.html

Last edited by RBURGOSS; 01-17-2013 at 09:38 AM.
RBURGOSS is offline  
#14 Old 01-17-2013, 12:07 PM
Junior Member
 
Join Date: Jan 2013
Location: rotherham
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ernwilson@msn.com is an unknown quantity at this point
(Thread Starter)
i still cant find the 2 glow relays am i thick or what.
ernwilson@msn.com is offline  
#15 Old 01-17-2013, 12:47 PM
MODERATOR
 
RBURGOSS's Avatar
 
Join Date: Aug 2009
Location: Costa Rica
Posts: 1,462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RBURGOSS is an unknown quantity at this point
Quote:
Originally Posted by ernwilson@msn.com View Post
i still cant find the 2 glow relays am i thick or what.

Look inside engine compartment. There are TWO fuse and relay boxes. A large one (No. 1) on the same side of the driver, between the firewall and the fuel filter. The other one is at the other side, next to the battery. This is on LHD models. I don't know if for RHD models this changes, but its there.

The glow relay (and main fuse) is inside this second fuse and relay box.
Attached Images
File Type: jpg TERRACAN RELAY BOX 2 ENGINE COMPART.jpg (89.7 KB, 9 views)

Robert B.

Don't forget to participate and vote in the February 2013 ROTM thread at http://www.hyundai-forums.com/249-ri...2013-rotm.html
RBURGOSS is offline  
#16 Old 01-24-2013, 02:05 PM
Junior Member
 
Join Date: Jan 2013
Location: rotherham
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ernwilson@msn.com is an unknown quantity at this point
(Thread Starter)
hiya rob ive checked both glow heaters they are ok. ive checked relay in box in engine compartment thats ok. on my diagram it shows 2 relays but i cant find the second one.i still have 0 voltage on 1 glow plug the other one work fine.
ernwilson@msn.com is offline  
#17 Old 01-24-2013, 03:51 PM
MODERATOR
 
RBURGOSS's Avatar
 
Join Date: Aug 2009
Location: Costa Rica
Posts: 1,462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RBURGOSS is an unknown quantity at this point
Quote:
Originally Posted by ernwilson@msn.com View Post
hiya rob ive checked both glow heaters they are ok. ive checked relay in box in engine compartment thats ok. on my diagram it shows 2 relays but i cant find the second one.i still have 0 voltage on 1 glow plug the other one work fine.

Yes, its tricky because the diagram makes you think both relays are located at the same place (next to each other)

Glow relay 1 is inside the fuse and relay box 2 in engine compartment. Glow relay 2 is by itself, outside this same box, bolted to the side, between the fuse box and washer bottle filler neck.
Attached Images
File Type: jpg GLOW RELAY 2 LOCATION J3 ENGINE.jpg (187.4 KB, 16 views)

Robert B.

Don't forget to participate and vote in the February 2013 ROTM thread at http://www.hyundai-forums.com/249-ri...2013-rotm.html
RBURGOSS is offline  
#18 Old 01-30-2013, 07:43 AM
Junior Member
 
Join Date: Jan 2013
Location: rotherham
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ernwilson@msn.com is an unknown quantity at this point
(Thread Starter)
hi rob ive check both air heater plugs and they are ok. i tested 1 relay in box in engine bay and thats working ok. on electrical drawing it shows 2 relays but i dont know where the 2nd one is. i still get 12v on one plug but nothing on the other. i have asked hyundai dealer but they havent got a clue.
ernwilson@msn.com is offline  
#19 Old 01-30-2013, 08:09 AM
MODERATOR
 
RBURGOSS's Avatar
 
Join Date: Aug 2009
Location: Costa Rica
Posts: 1,462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RBURGOSS is an unknown quantity at this point
Quote:
Originally Posted by ernwilson@msn.com View Post
hi rob ive check both air heater plugs and they are ok. i tested 1 relay in box in engine bay and thats working ok. on electrical drawing it shows 2 relays but i dont know where the 2nd one is. i still get 12v on one plug but nothing on the other. i have asked hyundai dealer but they havent got a clue.

Look at my previous post (#17). The second relay is outside this box, bolted to a bracket on the fender inside. The second relay is a bit bigger than the one inside the box. It has no markings but its easy to find. (Heater relay #2)

Robert B.

Don't forget to participate and vote in the February 2013 ROTM thread at http://www.hyundai-forums.com/249-ri...2013-rotm.html
RBURGOSS is offline  
#20 Old 01-31-2013, 09:19 AM
Junior Member
 
Join Date: Jan 2013
Location: rotherham
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ernwilson@msn.com is an unknown quantity at this point
(Thread Starter)
looking at your glow relay page it must be a LHD one mines a RHD. Cheers.
ernwilson@msn.com is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome