High Pressure Fuel Pump Leak? - Hyundai Forums : Hyundai Forum
Reply
 
LinkBack Thread Tools
#1 Old 05-14-2012, 10:47 AM
Senior Member
 
Join Date: Apr 2011
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dolsson
(Thread Starter)
High Pressure Fuel Pump Leak?

I noticed this months ago but dismissed it.

If you take the plastic decorative cover off you can then see the high pressure fuel pump and other goodies. The high pressure pump looks like a silver dome like thing.

Where the line (has an orange little clip thing on the end) connects to the pump, there appears to be an oily residue coating the pump (the silver dome like thing). I wonder if this means my pump is leaking or something?

I'm taking the car in this Friday for a regular service and I'm going to mention it.

Anyone else able to take a look and describe what they see? Is yours perfectly clean without any residue or oily stuff?

Thanks!
dolsson is offline  
Sponsored Links
Advertisement
 
#2 Old 05-14-2012, 03:08 PM
Senior Member
 
jasen1's Avatar
 
Join Date: Jan 2011
Location: Edmonton Alberta
Posts: 2,143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
jasen1 is an unknown quantity at this point
Ill take a look this evening and snap a picture for you.
jasen1 is offline  
#3 Old 05-14-2012, 07:56 PM
Senior Member
 
Join Date: Apr 2011
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dolsson
(Thread Starter)
Quote:
Originally Posted by jasen1 View Post
Ill take a look this evening and snap a picture for you.
Thanks man, I appreciate it. I hope there isn't something wrong with mine. It's all under warranty - but still.

Maybe it's just goo from the padding beneath the cover or something... Who knows.
dolsson is offline  
#4 Old 05-15-2012, 10:59 PM
Senior Member
 
jasen1's Avatar
 
Join Date: Jan 2011
Location: Edmonton Alberta
Posts: 2,143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
jasen1 is an unknown quantity at this point
Totally forgot about this. So sorry. I'll snap a picture in the morning and post it at work.
jasen1 is offline  
#5 Old 05-16-2012, 09:26 AM
Senior Member
 
jasen1's Avatar
 
Join Date: Jan 2011
Location: Edmonton Alberta
Posts: 2,143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
jasen1 is an unknown quantity at this point
Here is my picture. Hope it's good enough.

jasen1 is offline  
#6 Old 05-16-2012, 11:14 AM
Senior Member
 
Join Date: Apr 2011
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dolsson
(Thread Starter)
Quote:
Originally Posted by jasen1 View Post
Here is my picture. Hope it's good enough.

Thanks man. Yours looks a lot shinier than mine, with no residue on the pump at all. Mine is kinda oily or something. Wonder where it's coming from.

Guess I'll still be mentioning this when I take the car in Friday. For ****s sake.
dolsson is offline  
#7 Old 05-16-2012, 12:11 PM
Senior Member
 
jasen1's Avatar
 
Join Date: Jan 2011
Location: Edmonton Alberta
Posts: 2,143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
jasen1 is an unknown quantity at this point
good that you noticed it.
jasen1 is offline  
#8 Old 05-16-2012, 12:22 PM
Senior Member
 
Join Date: Apr 2011
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dolsson
(Thread Starter)
Quote:
Originally Posted by jasen1 View Post
good that you noticed it.
I know, you're right. But why would this be happening now? I find it hard to believe it's actually leaking.
dolsson is offline  
#9 Old 05-16-2012, 04:05 PM
Senior Member
 
sienna1's Avatar
 
Join Date: Apr 2011
Location: Ontario, Canada
2011 Sonata 2.4L Limited 2012 Veracruz GL FWD
Posts: 556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sienna1 is an unknown quantity at this point
Quote:
Originally Posted by dolsson View Post
I know, you're right. But why would this be happening now? I find it hard to believe it's actually leaking.
Mine had the same oily residue, the oily substance never returned after cleaning the area with brake-cleaner (several months now). It may be some type of assembly lube. I was investigating a fuel odor when I noticed the oily film, the problem turned out to be a collapse PCV hose.
sienna1 is offline  
#10 Old 05-16-2012, 04:09 PM
Senior Member
 
Join Date: Oct 2006
Location: .
.
Posts: 1,222
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Zebodog is an unknown quantity at this point
^^ +1 Probably some form of lube or protectant from assembly/shipping and it just attracted road grime.

Given the pressure the fuel is under, you would think any type of leak would be quite noticeable.
Zebodog is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome