HELP.. Engine has a "shake" with heat on & at a stop. - Hyundai Forums : Hyundai Forum
Reply
 
LinkBack Thread Tools
#1 Old 02-17-2012, 12:58 PM
Junior Member
 
Join Date: Feb 2012
Location: Northeast
Drives Sonata YF
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cro350 is an unknown quantity at this point
(Thread Starter)
HELP.. Engine has a "shake" with heat on & at a stop.

I thought others on the forum can verify if this is the way the car "just runs" or if there may be some other issue going on with the engine/heating controls by trying this with their Sonata's??. I have a 2012 2.0T w/ build date late November 2011.

1) the car runs fine and smooth with no heat turned on.(fan control off)
2) If the car is warmed up and I come to a traffic light with the heat on (auto or manual) I can feel a noticeable shake/shimmy coming from the engine through my steering wheel
3) If I hit the heat/fan off button while at the stopped light the car goes back to perfectly smooth???

So question is, can someone else replicate this? I have had many , many cars and have never felt this unless it was turning on the A/C and that may cause a slight shimmy in the engine, but never with heat??
Also my GAS mileage has always been lousy since i have had this car w/ 50/50% "light" split driving and avg 20 MPG....BTW.. Dealer did nothing when I brought it in for the MPG!....FYI ..plugs gapped to .32 brought it up from 18 MPG to 20 MPG. Just a Thought, heat shimmy issue might be impacting the other?
Thanks for any help on this...
cro350 is offline  
Sponsored Links
Advertisement
 
#2 Old 02-17-2012, 02:35 PM
Senior Member
 
BigSlick's Avatar
 
Join Date: Jan 2011
Location: Lakewood, NJ
Drives 2011 Sonata 2.0T
Posts: 1,073
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BigSlick
I would maybe expect that from turning the AC on only...but then again not on a new car. I would just take it back in to get it fixed cause my car doesn't do that. By the way I also get shitty gas mileage with mixed driving. With trying to be easy on the car all the time and not getting on it from a stop I get about 18-23. I can however get 34 on the parkway with the cruise on.

Appearance Mods: 25% SunTek Carbon tint, 6K HID lows and fog's; LED Interior; LED bulbs in taillights; Type C Spoiler
Performance Mods: K&N Filter
Coming Soon: Nameless Intake!
BigSlick is offline  
#3 Old 02-17-2012, 04:08 PM
 
Join Date: Nov 2010
Location: California
YF
Posts: 1,106
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mod King is an unknown quantity at this point
I have the same issue with my 2.4.

It also idles a little higher with the heat on...maybe a few hundred RPM.

By the way, I get 22.5 avg MPG mixed driving....very disappointed with that. Had my car for 2 years and only has 16,700 miles on it so I don't drive much at all.

Last edited by Mod King; 02-17-2012 at 04:10 PM.
Mod King is offline  
#4 Old 02-17-2012, 07:10 PM
Senior Member
 
sienna1's Avatar
 
Join Date: Apr 2011
Location: Ontario, Canada
2011 Sonata 2.4L Limited 2012 Veracruz GL FWD
Posts: 556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sienna1 is an unknown quantity at this point
With the Automatic Climate Control, even with heat selected the A/C compressor may still run depending on the outside and selected cabin temperature. It's can also run if the system is in defrost mode (auto or manually selected). With the Manual Climate Control system, the A/C can also cycle in defrost mode even when the temperature selector is in the warm band. This could explain the increase fuel consumption.
sienna1 is offline  
#5 Old 02-17-2012, 08:10 PM
Senior Member
 
Michael_V's Avatar
 
Join Date: Sep 2011
Location: Bawstin, MA
2012 Sonata SE Black/Black DOM 06/Sept/11
Posts: 451
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Michael_V is on a distinguished road
Does the of vibration rise with a higher fan setting? If it does, then the problem may be in the blower assembly. Not sure about Sonatas, but a lot of cars I have worked on have a "squirrel cage" type fan. If something gets in there and throws it out of balance it will vibrate like crazy.
Michael_V is offline  
#6 Old 02-18-2012, 11:22 AM
Senior Member
 
leesrt's Avatar
 
Join Date: Apr 2010
Location: Ga
Drives 2013 Genesis Coupe 3.8 Track and 2013 Elantra GT
Posts: 1,055
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
leesrt is an unknown quantity at this point
I think people need to specify how they calculate their mpg before they post about it because I notice many people who think they're getting bad mileage use the avg mpg display as their source. That is not accurate and quite often way off from what your really getting.

Mods: K&N air filter and BOV filter, 21% tint, T-bolt clamps, debadged and rebadged with KDM, 6k XS HID and LED, Lamin-X tinted Tails & Fogs
leesrt is offline  
#7 Old 02-18-2012, 12:49 PM
Junior Member
 
Join Date: Feb 2012
Location: Northeast
Drives Sonata YF
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cro350 is an unknown quantity at this point
(Thread Starter)
Quote:
Originally Posted by sienna1 View Post
With the Automatic Climate Control, even with heat selected the A/C compressor may still run depending on the outside and selected cabin temperature. It's can also run if the system is in defrost mode (auto or manually selected). With the Manual Climate Control system, the A/C can also cycle in defrost mode even when the temperature selector is in the warm band. This could explain the increase fuel consumption.

Sienna,

Thanks for replying, the issue is I make sure to NOT use the auto climate and to make sure that the arrows "lit up on the display" are the ones going to your feat and the ones going through the front dash output. i make sure to not have the upper defrost on, as that should turn on the AC compressor.....

Are you saying that even with only heat coming in to your feat area and front grill, the Ac can be cycling, becuase if that is true that would easilt rob 2-3 mpg and give me this shimmy/Shake.... Look forward to your response
cro350 is offline  
#8 Old 02-18-2012, 12:52 PM
Junior Member
 
Join Date: Feb 2012
Location: Northeast
Drives Sonata YF
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cro350 is an unknown quantity at this point
(Thread Starter)
Quote:
Originally Posted by Michael_V View Post
Does the of vibration rise with a higher fan setting? If it does, then the problem may be in the blower assembly. Not sure about Sonatas, but a lot of cars I have worked on have a "squirrel cage" type fan. If something gets in there and throws it out of balance it will vibrate like crazy.

No, Fan speed has no effect what so ever, it will shimmy the same amount even if you blast it to top speed, but as soon as you shut it off, the engine is as smooth as a baby's azz....

Has anyone been able to try this with their cars to see if the car if exactly the same smootness ones you put tyhe heat one? also, this is much more pronounced once the car has already been driven and warmed up....so lets say i have been driving it for 15 minutes or so... might be the car just idles higher or some ECU settings when cold....

Thanks for eveyone's help!
cro350 is offline  
#9 Old 02-18-2012, 12:58 PM
Junior Member
 
Join Date: Feb 2012
Location: Northeast
Drives Sonata YF
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cro350 is an unknown quantity at this point
(Thread Starter)
Quote:
Originally Posted by leesrt View Post
I think people need to specify how they calculate their mpg before they post about it because I notice many people who think they're getting bad mileage use the avg mpg display as their source. That is not accurate and quite often way off from what your really getting.

I would agree. I only use the same pump and gas and do the refill method X's the miles driven. But i have to be honest, the car ESTIMATE MPG has only been off no more then 1MPG on the high side so far and the car was about 1800 miles... so I'm avg 20mpg with combined 50% city(but not by any means manhattan city bumper to bumper stop and go) and 50% highway about 50 miles per hour avg. Same route each day and I have been granny drving her, i onlt get about 20 MPG , THAT SUX!!!! It's the one thing that realy pi$$es me off about this car as aside from it looking good, handling nice, it was the gas mileage on the sticker that combined 26 MPG that was a BIG selling point to me..... Not sure what to do at this point? seems like many others on here have the same bad MPG.. Straight HGWAY MPG is very good at around 35 but that only helps those who mostly do highway!
cro350 is offline  
#10 Old 02-18-2012, 10:27 PM
Junior Member
 
Join Date: Jun 2011
Location: Texas
Drives 2012 Sonata SE 2.0T Silver
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kennywiggin
Quote:
Originally Posted by cro350 View Post
I would agree. I only use the same pump and gas and do the refill method X's the miles driven. But i have to be honest, the car ESTIMATE MPG has only been off no more then 1MPG on the high side so far and the car was about 1800 miles... so I'm avg 20mpg with combined 50% city(but not by any means manhattan city bumper to bumper stop and go) and 50% highway about 50 miles per hour avg. Same route each day and I have been granny drving her, i onlt get about 20 MPG , THAT SUX!!!! It's the one thing that realy pi$$es me off about this car as aside from it looking good, handling nice, it was the gas mileage on the sticker that combined 26 MPG that was a BIG selling point to me..... Not sure what to do at this point? seems like many others on here have the same bad MPG.. Straight HGWAY MPG is very good at around 35 but that only helps those who mostly do highway!
I agree with you. I like everything about my experience with my SE Turbo except the fuel economy. I drive to work, ~40 miles round trip, on a highway with lights about once a mile. I hit about 5 red lights each way, so I would say that my driving conditions are "mixed". I do try to coast into the reds, and I accelerate moderately off the green.

So far, on my first 4 tanks of gas (just under 1200 miles so far) with 87 octane (from a Shell station, but who knows they really buy their gas from), I'm averaging around 23.5 MPG using the "distance/fill amount" method. The average per tank, according to my car has been between 24.8 and 25.6. Lifetime average is a head-scratching 28 MPG...odd. I was expecting something above the listed combined MPG since my route is more highway-like than city-like.

I have not had the guts to check my spark plug gaps, yet. The idle does seem just a tiny bit rough considering it is a new car. I have been running the automatic climate controls set to 75 degrees with the dual settings OFF.

Sorry, cro350, no help to your question. However I will try running a tank with just windows and vents (climate control completely off) and see what the MPG is like. Now is a good time since we've a mild winter.

Last edited by kennywiggin; 02-18-2012 at 10:30 PM.
kennywiggin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome