My AV Turbo Cord died - Hyundai Forums : Hyundai Forum
 2Likes
  • 2 Post By LimitedPlugIn
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 06-14-2017, 02:36 PM Thread Starter
Senior Member
 
LimitedPlugIn's Avatar
 
Join Date: May 2016
Location: Laurel, MD
2016 Hyundai Sonata Limited PHEV
Posts: 140
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
LimitedPlugIn is an unknown quantity at this point
(Thread Starter)
Unhappy My AV Turbo Cord died

Well, I will try to keep this short. I did a search and this problem does not appear to be common.

After I drove home and parked I went to plug in my turbo cord as I normally do when I return home. Unfortunately this time the wall plug clicked 5 times and then lit up pink/red. Tried again and same thing..would not charge the vehicle.

I contacted their customer support and spoke to a really nice guy Chris in less than two mins. I explained the issue to him and he right away said it was the power supply and he asked me to turn off the breaker for 20 minutes and then try again. Unfortunately, it did the same thing after. Chris had given me his direct number and extension to call him back. I called back and they are shipping me a new charger which should hopefully be here by Friday. They also sent me a UPS label to pay for return shipping of the defective cord.

Overall I am very happy with their customer service but just a bit bummed that my $600 charger died after little more than a year of use.

The original Level 1 charger that came with the car still works so I am using that until the replacement arrives.

Anyone else have this issue with the AV Turbo Cord?
Old's Cool and phftw like this.
LimitedPlugIn is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-15-2017, 08:47 PM Thread Starter
Senior Member
 
LimitedPlugIn's Avatar
 
Join Date: May 2016
Location: Laurel, MD
2016 Hyundai Sonata Limited PHEV
Posts: 140
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
LimitedPlugIn is an unknown quantity at this point
(Thread Starter)
Replacement cord arrived today. All is good!

Sent from my Nexus 6 using Tapatalk
LimitedPlugIn is offline  
post #3 of 4 (permalink) Old 06-16-2017, 11:35 AM
Member
 
Join Date: Dec 2016
Location: Suffolk, New York
Posts: 45
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
Kenny7 is an unknown quantity at this point
I've been using the Turbo Cord for about 1 1/2 years with no issues. I used it first with my Ford Fusion PHEV and now my Sonata PHEV. I'm using it for the quick charging 240v option.

I'm glad they're standing behind their product in your case. I suspect this was an unusual event.
Kenny7 is offline  
 
post #4 of 4 (permalink) Old 06-16-2017, 02:30 PM Thread Starter
Senior Member
 
LimitedPlugIn's Avatar
 
Join Date: May 2016
Location: Laurel, MD
2016 Hyundai Sonata Limited PHEV
Posts: 140
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
LimitedPlugIn is an unknown quantity at this point
(Thread Starter)
I agree it's an isolated thing. My wife said "your using it too much". I am very satisfied with their support and the RMA process. They sent the new cord overnight and sent me a shipping label to send the defective unit back.

Sent from my Nexus 6 using Tapatalk
LimitedPlugIn is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome