1529 Error Code - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
post #1 of 1 Old 05-14-2009, 02:52 AM Thread Starter
Junior Member
 
Join Date: May 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
edimax
(Thread Starter)
Hello everybody.
I have a Hyundai Tucson from 2006 with automatic transmission. I bought it second hand for a few months. For 2 months the check engine light is on. I have made a test and dicovered an error code p1529 - which seems to be a multfunction in the automatic transmission box. - no communcation. i have tried everything possible: I have changed the oil of the automatic transmission box, I have changed the valve which commands the covertor, but after a day, the check engine light is on again.
The cars works just fine, the only problem I have noticed is that, at higher speeds ( 100miles/hour) the turation is higher than normal (3500-4000rpm). But the cars works ok, no noise, no nothing.
Once the airbag light was on for a few days. But I erased the error code and it didn-t light since then. Maybe a conicidence, who knows.
I am just out of options. I am so upsat and I do not know what to do. There are thounsands of opinions but no one knows exaclty how to help me. In Romania there are a few Hyunday services and no one knows what to do.
If any of you had this problem,please help me.
I have run out of options.
Thank you.
edimax is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome