big problems 2006 V6 Santa Fe - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
post #1 of 1 Old 02-25-2014, 11:10 AM Thread Starter
Junior Member
 
Join Date: Feb 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
xroots is an unknown quantity at this point
(Thread Starter)
big problems 2006 V6 Santa Fe

Hi guys. I'm writing this hoping that anyone can point me a direction on how to fix this problem.

2 months ago my engine suffered from a overheat which made me change both the head cylinder gaskets.
2 days after this the engine started to shut down itself and wouldn't start, when we connected the diagnose scanner it started to throw this codes:

P0341
P0340

I know they are related to the camshaft sensors but the weird part is that after a few hours the car would start normally and drive with no problems, but like i said after a few days the engine stopped again and when i tried to turn it on it gave me a terrible sound.
The problem was that a piston connecting rod broke due to an excess of gasoline in one cylinder, it also broke the oil sump, it was a mess. even the exhaust was filled of gasoline.
I managed to gather all the pieces to assemble the engine again and also bought a new timing belt with all its tensioners from the local Hyundai dealer.

I started the engine a few days ago and it was all good for a few hours but then the same codes started to show again, P0341 and P0340.

I haven't replaced this sensors yet but i find no logic on having both die at the same time. at least in my experience.

My question basically is, is it normal to have both the crankshaft sensors die together?
Can a bad sensor could cause that excess of gasoline in one cylinder and cause all that damage i had in the engine?
I have checked the timing belt many times and i don't find anything wrong there, like a bad installation or anything about that.

I apologize for the bad English and thanks in advance for any tips on what to do. thanks again.
xroots is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome