Loss of power steering - Hyundai Forums : Hyundai Forum
Reply
 
LinkBack Thread Tools
#1 Old 06-24-2012, 03:19 PM
Junior Member
 
Join Date: Oct 2010
Location: SC
2006 Hyundai Sonata GLS V6 2012 Hyundai Genesis 3.8 V6
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
ricklaugh
(Thread Starter)
Loss of power steering

Greetings to all!

I have a 2006 Hyundai Sonata GLS V6 with about 135K miles.

I am experiencing intermittent loss of power steering. It usually happens when exiting off of an interstate highway. When I decelerate from 70 mph to 35 mph, it loses power steering. When I begin accelerating again, it usually comes back.

I have done the following:

1. Replace the harmonic balancer.
2. Reverse flush the power steering system and refill with new fluid. The independent mechanic states that the power steering pump appears to be working normally.
3. Replaced belts and hoses. The belt is not slipping.

The mechanic is stumped and has no idea why I would be experiencing this loss. He is unable to duplicate the problem.

Any ideas? I welcome your reply.

I posted an additional thread about the key not turning in the ignition. Not sure if it is related or not.

Many thanks!
ricklaugh is offline  
Sponsored Links
Advertisement
 
#2 Old 06-24-2012, 03:31 PM
Senior Member
 
Join Date: Mar 2010
Location: FL
2006 Sonata V6 GLS - was mine, but now my moms.
Posts: 578
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Byron007 is an unknown quantity at this point
Honestly, I don't know I'm just guessing. Perhaps your power steering pump is bad? I changed the fluid at 98k on mine, I simply took of the return line and got 2/3rds out. I put in 24 OZ of Hyundai power steering fluid back in there. Cured the whine in the mornings. Old fluid looked disgusting, smelled it too. How does he know your power steering pump is fine?
Byron007 is offline  
#3 Old 06-24-2012, 03:43 PM
Junior Member
 
Join Date: Oct 2010
Location: SC
2006 Hyundai Sonata GLS V6 2012 Hyundai Genesis 3.8 V6
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
ricklaugh
(Thread Starter)
Thank you, Byron007. When the mechanic test drives the car, the power steering works normally. He is unable to duplicate the problem.
ricklaugh is offline  
#4 Old 06-24-2012, 03:48 PM
Senior Member
 
ActionMan's Avatar
 
Join Date: May 2010
Location: Mile High, Colorado
2009 Hyundai Sonata GLS 2.4L I4 AT - Slate Blue
Posts: 1,084
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ActionMan is an unknown quantity at this point
Well, it would seem to me that in order for the mechanic to duplicate the problem he would need to replicate the circumstances under which you experience the problem. Has he tested it while exiting the highway going from 70 to 35 MPH? I'm guessing as well, but it does sound like a bad steering pump as Byron007 has suggested.


Vehicles Owned:
  • 2009 Hyundai Sonata GLS
  • 2001 Saturn L200
  • 1986 Saab 900 Turbo
  • 1979 Datsun 210
  • 1973 Mercury Montego
ActionMan is offline  
#5 Old 06-24-2012, 04:25 PM
Junior Member
 
Join Date: Oct 2010
Location: SC
2006 Hyundai Sonata GLS V6 2012 Hyundai Genesis 3.8 V6
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
ricklaugh
(Thread Starter)
Yes, he replicated the circumstances, but could not duplicate the problem. It doesn't do it all of the time. Perhaps 10% of the time.
ricklaugh is offline  
#6 Old 06-24-2012, 05:33 PM
Senior Member
 
Join Date: Jan 2007
Location: MA
Drives 2012 Sonata Limited Turbo
Posts: 406
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
error666 is an unknown quantity at this point
You have a ghost in your car. Ignition, power steering...
error666 is online now  
#7 Old 06-24-2012, 05:51 PM
Senior Member
 
Join Date: Mar 2010
Location: FL
2006 Sonata V6 GLS - was mine, but now my moms.
Posts: 578
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Byron007 is an unknown quantity at this point
I've been in a semi where the power steering pump would fail while trying to back up and then start working. The mechanics thought I was lying and didn't want to fix because it worked fine for them. More than likely the pump.
Byron007 is offline  
#8 Old 06-25-2012, 08:03 PM
Junior Member
 
Join Date: Oct 2010
Location: SC
2006 Hyundai Sonata GLS V6 2012 Hyundai Genesis 3.8 V6
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
ricklaugh
(Thread Starter)
OK, picked up the car from JR's Automotive in Lexington, SC. Here is what he said.

Of course, the power steering was working fine when he test drove the car. However, he found these three codes in the computer:

C1612 (can timeout TCU)
C1611 (can timeout EMS)
C1260 (steering sensor abnormal)

(Note: I have no idea what any of these mean)

He cleared the codes and recalibrated the steering angle sensor. He then test drove the car with the scanner and none of the codes reset.

So, if I lose power steering again, I will take it back and he will scan for new codes. Then we will proceed accordingly.

Also, he says the harmonic balancer, belt, p/s pump, and fluid all look good.

All of this for $79.00. That seems like a bargain to me! Very pleased.

So, praying that this fixed it. Time will tell. I will update if anything new develops.

Thanks!
ricklaugh is offline  
#9 Old 06-26-2012, 04:06 AM
Senior Member
 
Sequoiasoon's Avatar
 
Join Date: Mar 2007
Location: Long Island, New York
'07 Sonata 2.4L GLS 5 speed manual
Posts: 846
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Sequoiasoon is an unknown quantity at this point
There was a post somewhere with either a TSB or some related from SBR711 that mentioned a filter screen in the power steering reservoir iirc. Needs to be taken out/cleaned or replaced.
Sequoiasoon is offline  
#10 Old 06-26-2012, 11:03 AM
Senior Member
 
Join Date: Apr 2011
Former Hyundai owner. Good riddance.
Posts: 466
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
stephen9666 is an unknown quantity at this point
Quote:
Originally Posted by Sequoiasoon View Post
There was a post somewhere with either a TSB or some related from SBR711 that mentioned a filter screen in the power steering reservoir iirc. Needs to be taken out/cleaned or replaced.
This is what I was going to point out, too.

On my Sonata, I was experiencing the same problem as the OP. My balancer pulley was fine, so I didn't replace it.

I replaced the belt, which I know the OP already tried. But, when I had the belt off, I noticed some buildup of gunk on some of the pulleys. I suspect this may have been making the belt slip. I cleaned it out of the grooves of the pulleys, replaced the belt and the problem hasn't returned.

Check out my Youtube page for some NF Sonata how-to videos
stephen9666 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome