Rough Idle - Hyundai Forums : Hyundai Forum
Reply
 
LinkBack Thread Tools
#1 Old 04-29-2011, 11:01 AM
Member
 
Join Date: Mar 2011
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
imkramer
(Thread Starter)
Unhappy

My 2011 Elantra has a slightly rough idle at stop lights. It doesn't happen ever time, and some people probably wouldn't even notice it, but at every few/several stops it idles a bit rough. When I recently had it in to Hyundai service for the ECM update, I asked them to take a look at it. Of couse, they couldn't replicate it at the time, so they couldn't do anything to address it directly. The service manager asked if it happens when the A/C is on or off. While I didn't know the answer at the time, it seems to happen with it both on or off. He did say that the ECM update may address/fix the issue, but unfortunately it didn't. While it's not a big problem, it's a minor annoyance I'd like to get fixed (as I need to enjoy my ride at all times ).

Anybody else notice this with their car and, if so, have you done anything about it? Any other suggestions are welcomed - especially from those who understand what causes the car to idle like that.
imkramer is offline  
Sponsored Links
Advertisement
 
#2 Old 04-29-2011, 11:07 AM
SENIOR MODERATOR
 
someguy's Avatar
 
Join Date: Feb 2011
Location: Louisville, KY
2011 Elantra GLS 2009 Pathfinder
Posts: 8,295
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
someguy is an unknown quantity at this point
Garage
Mine too, happens when the ac is on or off intermittently at stoplights I haven't bothered to take it in yet since I dont want my car to end up as a testbed since this is a very minor problem. It started doing it less when I switched to synthetic oil but for now my solution is to drop the car into N at a light. I'm thinking there may be a bad iacv, or maf, also possibly a motor mount or a minor vacuum issue.


2011 Titanium Gray Elantra GLS
someguy is offline  
#3 Old 04-29-2011, 11:31 AM
Senior Member
 
strick3963's Avatar
 
Join Date: Mar 2011
Location: West Virginia
2011 Elantra GLS
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
strick3963
I've had a slight noise also that doesn't happen all the time. Someone on here mentioned that the Oil Control Valve is loud on these motors and that might be the culprit. I've only had mine for 3 1/2 weeks and have not taken it back in for the ECM update. Did you notice a difference in the way the car shifts after the ECM update?
strick3963 is offline  
#4 Old 04-29-2011, 11:43 AM
Member
 
Join Date: Jul 2010
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ponieus
I too just had my 11 limited in the service bay for the excat same issue. Odd thing was there was a GLS there for the excat same thing. I spoke to the tech and he made a report on it and hopefully if more would take them in for the issue Hyundai will look deeper into it cause, even the mechanic told me it shouldnt do the rough idle thing. He told me it seemed as if the idle control doesnt account for the a\c sometimes.

So I would recommend that anyone that has this issue take it in so the paper trails start and Hyundai sees there might be a small issue here that justs needs a tweak.


ponieus is offline  
#5 Old 04-29-2011, 11:53 AM
Senior Member
 
dpdurst's Avatar
 
Join Date: Apr 2008
Location: Arizona
Posts: 288
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dpdurst
I only notice the issue with the A/C running at a stop light. Sometimes its not as noticeable than other times
dpdurst is offline  
#6 Old 04-29-2011, 11:55 AM
Member
 
Join Date: Mar 2011
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
imkramer
(Thread Starter)
QUOTE (NPMountaineer @ Apr 29 2011, 11:31 AM)
Quote:
Did you notice a difference in the way the car shifts after the ECM update?
Yes, it reacts instantly now, rather than having a 1/2 second lag when you initially "step on the gas." So it's much more responsive now. Haven't noticed any real differnce in how the transmission shifts once "at speed" though. Then again, I never noticed any issue as far as that's concerned. If your car is included in the ECM Update TSB Campaign production date range, I would suggest getting it done.
imkramer is offline  
#7 Old 04-29-2011, 12:26 PM
SENIOR MODERATOR
 
someguy's Avatar
 
Join Date: Feb 2011
Location: Louisville, KY
2011 Elantra GLS 2009 Pathfinder
Posts: 8,295
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
someguy is an unknown quantity at this point
Garage
ponieus Interesting I need to run to dealer tomorrow morning for touchup paint, will stop by the service desk and ask if they have seen this much yet.


2011 Titanium Gray Elantra GLS
someguy is offline  
#8 Old 04-29-2011, 03:09 PM
Senior Member
 
Don67's Avatar
 
Join Date: Jan 2008
Location: Ottawa, Canada
Drives 2012 Veracruz GL FWD, 2011 Elantra GLS Auto. Former 2008 Santa Fe 3.3 AWD
Posts: 5,229
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Don67 is an unknown quantity at this point
I've noticed an occasional shaking at idle too... more than I would expect from a small 4-banger. I suspect it's triggered by the A/C cycling on and off, but cannot say for sure.

PS: Someguy, I haven't noticed any difference since switching to synthetic.. nor would I expect any.
Don67 is offline  
#9 Old 04-29-2011, 03:24 PM
Senior Member
 
joemidnight's Avatar
 
Join Date: Apr 2011
Location: Canada
Posts: 402
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
joemidnight is an unknown quantity at this point
QUOTE (ImKramer @ Apr 29 2011, 11:01 AM)
Quote:
My 2011 Elantra has a slightly rough idle at stop lights. It doesn't happen ever time, and some people probably wouldn't even notice it, but at every few/several stops it idles a bit rough. When I recently had it in to Hyundai service for the ECM update, I asked them to take a look at it. Of couse, they couldn't replicate it at the time, so they couldn't do anything to address it directly. The service manager asked if it happens when the A/C is on or off. While I didn't know the answer at the time, it seems to happen with it both on or off. He did say that the ECM update may address/fix the issue, but unfortunately it didn't. While it's not a big problem, it's a minor annoyance I'd like to get fixed (as I need to enjoy my ride at all times ).

Anybody else notice this with their car and, if so, have you done anything about it? Any other suggestions are welcomed - especially from those who understand what causes the car to idle like that.

i can honestly say that while i am stopped at the lights, if i dont have my fan on, my car is so quiet that it feels like its not running

joemidnight is offline  
#10 Old 04-29-2011, 03:31 PM
Senior Member
 
chrisvm31's Avatar
 
Join Date: Mar 2009
Location: Ontario, Canada
Drives 2011 Elantra GLS (Canadian version)
Posts: 1,981
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
chrisvm31 is an unknown quantity at this point
Send a message via MSN to chrisvm31 Send a message via Yahoo to chrisvm31
QUOTE (Joemidnight @ Apr 29 2011, 03:24 PM)
Quote:
i can honestly say that while i am stopped at the lights, if i dont have my fan on, my car is so quiet that it feels like its not running
+1. When I first got the car, I turned the ignition and was like "WTF? Why isn't it turning on???" LOL
chrisvm31 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome