EPS Mafunctioning in my i10 Era - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
post #1 of 1 Old 08-12-2013, 02:20 AM Thread Starter
Junior Member
 
Join Date: Aug 2013
Location: Ahmedabad, Gujarat, India
Drives i10 Era
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
aykenayar is an unknown quantity at this point
(Thread Starter)
EPS Mafunctioning in my i10 Era

I am facing the EPS malfunctioning in my Hyundai i10 Era which I bought from Sharma Hyundai, Ahmedabad in Sept. 2009. At present the car is with their Naroda Workshop. According to them, the estimated cost for replacement would be around Rs.20K. I am shocked, as the vehicle is not yet completed its 4 years run, and before that this huge amount for a single replacement!!! Is it not a technical problem? I expect the company to replace the same free of cost. In fact, with my reference, the dealer could sell 4 units of Hyundai cars (two i20 and one i10 to my office staff and one Getz to my cousin). I request the company to consider this issue also while taking a policy on replacement in my car.
aykenayar is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome