Idle Problems - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
#1 Old 08-07-2013, 09:11 PM
Junior Member
 
Join Date: Aug 2013
Location: West Jordan
2003 Hyundai Tiburon 2.7 GT V6
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
TiburonThayne is an unknown quantity at this point
(Thread Starter)
Exclamation Idle Problems

Hello fellow Hyundai owners. Recently I replaced my BCM in my 03 tiburon, everything seemed to be running fine and a check engine light came on. MAF sensor replaced, intake cleaned, but still has a hesitant idle, as well will shut off when it is in idle ocassionally. I've taken a look at my MAP sensor and the cover for the wiring is missing and it looks like some sort of oil caked on the housing of the sensor itself. just need some opinions on other possibilities that could cause this problem, thanks, it would be very much appreciated
TiburonThayne is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome