2007 Entourage power sliding door troubleshooting - Page 7 - Hyundai Forums : Hyundai Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #61 of 68 (permalink) Old 05-07-2016, 09:28 PM
Junior Member
 
Join Date: Apr 2016
Posts: 8
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Bruno S4 is an unknown quantity at this point
Quote:
Originally Posted by Bruno S4 View Post
Hello guys, need some help here.
2007 Entourage GLS located in the Toronto area.

I've always had issues with the sliding doors but the biggest one has been frozen doors in the winter (the van stays outside all year).

Well years of reefing on the handles to get the doors open has taken it's toll.
My main issue is that the exterior handle for the drivers side power door does not open the door anymore.
If I push the button on the door jam its fine.
If I use the overhead buttons or key fob or the interior handle it opens just fine.

Just the exterior handle does not work.

So my Hyundai dealership (Richmond Hill) just diagnosed it and wanted to change all kinds of parts for a grand total of $2000! LOL! Common sense says just change the handle as something inside is broken but the technician says that will not work.

Has this happened to anyone else?

Thinking of going to Kia dealership instead as some previous posts recommended....
Just want to update.
I ended up ordering a door handle ($100 give or take) and took apart the inside panel of the sliding door.
Wow was it more difficult than I thought.
And for some reason there was tons of black goop behind the white plastic wrap...
Using the youtube videos I found I saw how to remove the motor and gain access to the door handle behind.
But once I had the motor out I looked closer at the handle and it seemed to work fine?
So after farting around with it for a while I put the motor back in and reinstalled all the bolts and electrical connectors.
Well to my surprise the door handle works fine now??
Didn't have to use the new one. Hope the dealer will take it back as I took it out of the bag.

So one problem down....

Thanks for the advice!
Bruno S4 is offline  
Sponsored Links
Advertisement
 
post #62 of 68 (permalink) Old 09-21-2016, 11:19 AM
Junior Member
 
Join Date: Sep 2016
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
jricci is an unknown quantity at this point
Hi friends, can you help me ??
Left door opens from the button on the roof, pillar button and the remote control. But never closes. Sometimes it does not open or warning sound, does nothing. After a while back to do the same, just open.
IN THIS DOOR I REPLACE ACTUATOR, and to my disappointment still behaving the same way.
What else might be causing the problem. Most have to check ??

Right door just makes the sound from the roof button or button pillar not open or close. This door is dead.
IN THIS DOOR NO HE REPLACED THE ACTUATOR, I try to replace it? Or both doors have a flaw in common?

What is the function of this actuator? It is what moves the whole door? or the door moves another main engine, which is on the rear panel?


Thank you very much for your help, I thought I had found the solution with the actuators but sadly it was not.
regards
Julian
jricci is offline  
post #63 of 68 (permalink) Old 01-09-2017, 01:06 PM
Member
 
Join Date: Apr 2013
Location: Kalamazoo MI
Drives Hyundai Entourage
Posts: 61
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
jessman1128 is an unknown quantity at this point
Quote:
Originally Posted by sbr711 View Post
You have to purchase the complete motor, comes with cables installed and ready to bolt to body, and connect cables to door
penkarameet, did you replace the motor and cables? If so, at a dealer, or DIY? I have the exact same issue on my passenger side door now and I need to decide whether to attempt it myself or take it to my dealer.

sbr711, is there any way to convert the door to manual operation without fixing the broken cable? The door will currently only open a few inches with the broken cable. The cable that is still present runs into the frame rearward of the door, and it seems to be attached to something just inside the frame that is preventing it from being pulled outward any more, thus preventing the door from being opened more than a few inches.

"The LORD gave, and the LORD has taken away;
Blessed be the name of the LORD."
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

Last edited by jessman1128; 01-09-2017 at 01:13 PM. Reason: Adding question to sbr711
jessman1128 is offline  
 
post #64 of 68 (permalink) Old 01-22-2017, 02:06 PM
Member
 
Join Date: Oct 2016
Posts: 45
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Pete in PA is an unknown quantity at this point
Joy, oh joy! You can now add me to the list of people with Entourage PSD problems. And just when I ready to move on to creature comforts like new struts...

I've been sick for going on two weeks and feeling miserable. Kind of a shi$%y week at work with some irritations like seized suspension component fasteners, easy-connect BMW cooling system hoses that won't easy-disconnect, drilling out bolts on a Volvo steering column lock to replace it, etc. Fun, fun, fun.

So I'm finishing up my last job of the week, yesterday, with BMW coolant dripping on my head, and my wife calls my cell: "uh, the driver's side sliding door on the van won't close."

Great. And it's been drizzling/misting here for days.

I told her to drive the van home with the door open and when I got there the symptom was that the door would *try* to close when you used any of the normal closing methods but seemed to be jammed at the bottom, forward corner. After trying various things to get the door closed for the night I gave up and threw a sheet of plastic over it.

This morning I went out to troubleshoot and *surprise* the door is now totally unresponsive. Just the "beeeeep" warning tone when you use the key fob, b-pillar button, or roof console button.

It's going to be fun to remove the interior trim panel with the door stuck open, eh?

If anyone has any suggestions I'm all ears. sbr, are you out there?
Pete in PA is offline  
post #65 of 68 (permalink) Old 01-23-2017, 05:15 PM
Member
 
Join Date: Oct 2016
Posts: 45
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
Pete in PA is an unknown quantity at this point
The problem with my van's PSD is resolved and I'm sorry to say that the problem was probably self-inflicted.

So from working on other van's with PSDs it was pretty obvious that the latch/unlatch part of the system was FUBAR on my van and not the slide forward/rearward portion. The door was definitely *trying* to move forward but it seemed like it couldn't release from whatever held it in the full rearward position. And, as is turns out, that's because it couldn't release from whatever held it in the full rearward position.

I have to say that, in the back of my mind, I kept thinking "this couldn't possibly have anything to do with my replacement of the outside door handle a couple of months ago, could it?" "Nah, no way." And yet, it did.

The door couldn't unlatch from the rearmost position because the bowden cable sheath attached to the inside handle assembly had popped off its little metal retaining fork. I had to take all this stuff apart when I replaced the outside handle so I guess I screwed up during reassembly. The little white plastic sleeve you see in the pic below slides onto a metal retaining fork. No problem. But if you push harder that little white sleeve will go over a barb and slide farther onto the retainer. I didn't notice that and paid the price.

So I got to remove the interior trim panel with the door open and that wasn't as bad as I thought it would be. After spotting the problem and properly affixing the cable sheath the PSD still wouldn't work because the module had locked it out electronically. I was, however, able to manually close the door and that was a big deal because its been raining here for 2 days.

With the engine running and the cabin warming up/dehumidifying, I threw caution to the wind and hit the door open button on the overhead console. Ta daaa! The door opened. When it hit the end of rearward travel, though, I heard a double beep. Uh oh, that can't be good. Pushed the overhead console button again and the door closed normally. Awesome. Opened the door again and it reached the end of travel without making any beeps. Great! I guess the module was initially letting me know that something wasn't right. By the second cycle everything was back in sync so no warning beeps.

With 112k miles on the van I'm sure this won't be the last time I have those door panels off but at least all is well for now. On to front struts...
Attached Images
File Type: jpg IMG_0685.JPG (144.6 KB, 7 views)
Pete in PA is offline  
post #66 of 68 (permalink) Old 03-07-2017, 09:16 AM
Member
 
Join Date: Apr 2013
Location: Kalamazoo MI
Drives Hyundai Entourage
Posts: 61
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
jessman1128 is an unknown quantity at this point
Our driver's side sliding door is acting up now. It started not latching closed on Sunday. I know I can replace the latch mechanism, because I already replaced the one in the passenger side door a few years ago. However, since it started not latching closed, it has been exhibiting other issues as well. Sometimes the door can be opened and closed (albeit not latched closed) manually with no issues. Other times it takes a ridiculous amount of effort to force the door open or closed. Sometimes the power option does not work at all. Other times it works to open the door, and it works to close the door, but since it cannot latch it beeps and then opens back up all the way.

Are these other sporadic issues likely to go away once I replace the latch mechanism, or am I looking at additional parts that will need to be replaced?

"The LORD gave, and the LORD has taken away;
Blessed be the name of the LORD."
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
jessman1128 is offline  
post #67 of 68 (permalink) Old 03-15-2017, 01:07 PM
Member
 
Join Date: Apr 2013
Location: Kalamazoo MI
Drives Hyundai Entourage
Posts: 61
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
jessman1128 is an unknown quantity at this point
Our passenger sliding door is now functioning correctly, so I wanted to post an update on what I did to resolve the issues in case it helps future troubleshooting from other Entourage/Sedona owners.

The primary initial problem seemed to be with the door latch. When using the power system, the door would close completely, but would fail to latch, and would subsequently beep and open back up all the way. When closing the door manually, it would latch sometimes and not latch at other times. I obtained a replacement latch from my dealer and installed it myself on a very chilly Michigan winter late night. I didn't take any pictures due to the darkness and cold. I'll try to remember to open the door back up and take some pics once the temperature warms up a bit.

With the door latch replaced, the door started latching correctly when closing the door manually. Power operation was still troublesome though. The door would close completely, but not latch, beep 3 times, and then open all the way, followed by another 3 beeps. Researching this on this site and other sites, the 3 beeps seemed to be an indication of the anti-pinch strip sensor - meaning the sensor was thinking something was in the path of the door. I found the procedure for re-learning the power door, and decided to try that, because it seemed like the system was just confused about the open and close positions for the door. I followed the power door re-learn procedure, and the power operation has worked correctly since then. The power door re-learn procedure is described below.

1) Door needs to be closed, and ignition in OFF position.
2) Locate the system SHUNT fuse. It is in the fuse panel that is located to the lower left of the steering wheel column. The back of the fuse panel cover has this fuse labeled as SHUNT.
3) Pull out (but do not remove) the SHUNT fuse. Wait 30 seconds. Push it back in. (I wasn't really sure how far to pull it out - I pulled it out about the distance of the height of a typical mini-fuse.)
4) Use any power input to open and close the door 3 times. (I just remembered the first time I opened the door in this step it beeped at me. The remaining close and opens were beep-free though!)

"The LORD gave, and the LORD has taken away;
Blessed be the name of the LORD."
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
jessman1128 is offline  
post #68 of 68 (permalink) Old 03-15-2017, 03:05 PM
Junior Member
 
Join Date: Jun 2016
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
angelmiajo is an unknown quantity at this point
Thank you. We need to do some work on the door and I think this will be a huge help.

Sent from my SAMSUNG-SM-G920A using Tapatalk
angelmiajo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome