Oil leak - Hyundai Forums : Hyundai Forum
Reply
 
LinkBack Thread Tools
#1 Old 07-31-2012, 06:49 PM
Senior Member
 
TomcatVet's Avatar
 
Join Date: Feb 2011
Location: Pittsburgh, PA
Drives 2011 Santa Fe, limited
Posts: 157
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
TomcatVet
(Thread Starter)
Oil leak

Just took in my 2011 Santa Fe Limited for its 22,500 mile service (oil change). I was informed that it had an "oil leak under the front cover," and it needs to be fixed before it ruins the alternator. I will have to drop it off again for a whole day to have it fixed under warranty. The service rep also told me that this was not uncommon. I did a search of the forum but didn't find anything where other Santa Fe owners have had a similar problem. A little disturbing.
TomcatVet is offline  
Sponsored Links
Advertisement
 
#2 Old 07-31-2012, 08:35 PM
Senior Member
 
Don67's Avatar
 
Join Date: Jan 2008
Location: Ottawa, Canada
Drives 2012 Veracruz GL FWD, 2011 Elantra GLS Auto. Former 2008 Santa Fe 3.3 AWD
Posts: 5,275
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Don67 is an unknown quantity at this point
Quote:
Originally Posted by TomcatVet View Post
Just took in my 2011 Santa Fe Limited for its 22,500 mile service (oil change). I was informed that it had an "oil leak under the front cover," and it needs to be fixed before it ruins the alternator. I will have to drop it off again for a whole day to have it fixed under warranty. The service rep also told me that this was not uncommon. I did a search of the forum but didn't find anything where other Santa Fe owners have had a similar problem. A little disturbing.
It has been reported here before. Mine is leaking over the alternator too. My valve cover bolts were loose, although I'm not 100% sure that was the problem. Will mention it when my 'Fe goes in for the airbag recall.
Don67 is offline  
#3 Old 07-31-2012, 09:22 PM
senior member
 
wymi's Avatar
 
Join Date: May 2007
Location: Chicago, Illinois
Drives: Hyundai & KIA
Posts: 3,784
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
wymi is an unknown quantity at this point
My 09 Santa Fe was leaking too. I tightened the valve cover bolts quite a while ago and the leak did stop. FWIW, I probably over tightened them a little but the leak did stop. I check it often to make sure it stays dry, the alternator won't last too long soaked in oil. My dealer is a real pain to deal with so I'm glad the leak stopped.

wymi is offline  
#4 Old 08-01-2012, 12:55 AM
Senior Member
 
Join Date: May 2007
Location: Palatine,IL USA
2007 SantaFe AWD Limited 3.3
Posts: 304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
steveH
Quote:
Originally Posted by TomcatVet View Post
Just took in my 2011 Santa Fe Limited for its 22,500 mile service (oil change). I was informed that it had an "oil leak under the front cover," and it needs to be fixed before it ruins the alternator. I will have to drop it off again for a whole day to have it fixed under warranty. The service rep also told me that this was not uncommon. I did a search of the forum but didn't find anything where other Santa Fe owners have had a similar problem. A little disturbing.
Search for alternator failure due to oil leak, I had the problem and they found that the rubber gasket sometimes isnt put in right or gets kinked right at the point above the alternator. This was a known problem and should be fixed under warranty. Funny havent heard it happening on the 2011 I thought they might have changed the gasket material or at least had better quality control. If the alternator has a coating of oil on it put up a stink they should replace it as well as fix the gasket under warranty.
steveH is offline  
#5 Old 08-02-2012, 08:12 AM
Senior Member
 
Don67's Avatar
 
Join Date: Jan 2008
Location: Ottawa, Canada
Drives 2012 Veracruz GL FWD, 2011 Elantra GLS Auto. Former 2008 Santa Fe 3.3 AWD
Posts: 5,275
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Don67 is an unknown quantity at this point
Quote:
Originally Posted by steveH View Post
they found that the rubber gasket sometimes isnt put in right or gets kinked right at the point above the alternator. This was a known problem
In that case wouldn't the leak start right away when the vehicle is new?

Most of the posts I've read - and indeed my own experience - suggest that the leak begins after 3 or 4 years of service. Like wymi I discovered loose valve cover bolts at that time, but I am not 100% sure that snugging them down has stopped the leak completely.
Don67 is offline  
#6 Old 08-02-2012, 10:10 AM
Senior Member
 
TomcatVet's Avatar
 
Join Date: Feb 2011
Location: Pittsburgh, PA
Drives 2011 Santa Fe, limited
Posts: 157
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
TomcatVet
(Thread Starter)
It goes in Monday, for the whole day so I'm assuming that it is more than a valve cover gasket but a shaft seal perhaps. I'll post more when it is done. Glad it is under warranty, not so glad for the annoyance of having to take the care in again.
TomcatVet is offline  
#7 Old 08-02-2012, 09:59 PM
Senior Member
 
sn20202020's Avatar
 
Join Date: Nov 2007
Location: Ontario
'07 SantaFe 3.3L AWD 7Seats
Posts: 356
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
sn20202020
Snugging didn't stop my leak. so I changed the gasket.

Valve Cover Gasket ?
sn20202020 is offline  
#8 Old 08-03-2012, 09:59 PM
Member
 
Join Date: Jan 2008
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cime_sp
I'm on my 3rd alternator before they figured out it was the valve cover gasket. Pretty common problem. Redesigned gasket has seemed to fix problem recently though
cime_sp is offline  
#9 Old 08-04-2012, 10:33 PM
Junior Member
 
Join Date: May 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
maggiem
Hi all, just got my 2011 santa fe back from dealer about two weeks ago,had oil leak at timing chain cover and valve covers they had car all day, but work covered under warranty.I could not find anything on oil leaks on timing chain covers so i hope this is not going to be a on going problem.
maggiem is offline  
#10 Old 08-07-2012, 07:23 AM
Senior Member
 
TomcatVet's Avatar
 
Join Date: Feb 2011
Location: Pittsburgh, PA
Drives 2011 Santa Fe, limited
Posts: 157
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
TomcatVet
(Thread Starter)
Just an update, the dealer is having problems finding the leak, so they still have the car. They suspect a shaft seal...just lovely
TomcatVet is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome