Fog light is not working - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-01-2012, 08:56 PM   #1 (permalink)
Member
 
Join Date: Nov 2010
Posts: 92
Gary0100
Default Fog light is not working

My fog light is not on anymore... Sad
Gary0100 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-01-2012, 09:53 PM   #2 (permalink)
Senior Member
 
CHiSEEN's Avatar
 
Join Date: Nov 2011
Location: Queens, New York
Drives 2012 Hyundai Sonata Limited 2.0T
Posts: 438
CHiSEEN is an unknown quantity at this point
Default

Need more details than that to suggest anything.
Did you check the bulbs? Wiring harnesses? Any mods?

If all else fails take it to the dealer.
__________________
Harbor Gray
2012 Hyundai Sonata 2.0T Limited
XS 6000K HID Low Beams | PIAA 2500K Plasma Ion Yellow Fog Lights | SR LED DRL | MOBIS Tail Lights | VLED 5000K Reverse Lights | PLED 8000K LED Interior Lighting | LED Cupholder Mod | SR Black Fog Light Molding | MOBIS Chrome Lower Door Molding | SR Rear Diffuser - Type 2 | 35% Tint All Around
CHiSEEN is offline   Reply With Quote Quick reply to this message
Old 03-01-2012, 09:58 PM   #3 (permalink)
Member
 
Join Date: Nov 2010
Posts: 92
Gary0100
Default

Becease my headlight n fog light are hid and they is the problem if I take it back to dealer
Gary0100 is offline   Reply With Quote Quick reply to this message
Old 03-01-2012, 10:35 PM   #4 (permalink)
Senior Member
 
sienna1's Avatar
 
Join Date: Apr 2011
Location: Ontario, Canada
2011 Sonata 2.4L Limited 2012 Veracruz GL FWD
Posts: 535
sienna1 is an unknown quantity at this point
Default

Quote:
Originally Posted by Gary0100 View Post
My fog light is not on anymore... Sad
Did you use a relay-harness? If not, you may have released the magic smoke from your junction box ($700 worth).
sienna1 is offline   Reply With Quote Quick reply to this message
Old 03-01-2012, 11:00 PM   #5 (permalink)
Member
 
Join Date: Nov 2010
Posts: 92
Gary0100
Default

I used relay it was fine for one year but start from 2 days ago my fog light is on sometimes n don't working sometimes
Gary0100 is offline   Reply With Quote Quick reply to this message
Old 03-01-2012, 11:05 PM   #6 (permalink)
Senior Member
 
jasen1's Avatar
 
Join Date: Jan 2011
Location: Edmonton Alberta
Posts: 2,073
jasen1 is an unknown quantity at this point
Default

most likely you have a bad ballast that sometime fires and sometimes doesn't. Turn them off.. count to 5 and turn them back on. That should do it. If not, cycle them again.
jasen1 is offline   Reply With Quote Quick reply to this message
Old 03-01-2012, 11:06 PM   #7 (permalink)
Senior Member
 
jasen1's Avatar
 
Join Date: Jan 2011
Location: Edmonton Alberta
Posts: 2,073
jasen1 is an unknown quantity at this point
Default

Quote:
Originally Posted by sienna1 View Post
Did you use a relay-harness? If not, you may have released the magic smoke from your junction box ($700 worth).
that typically shows up as a signal light on the passenger side that will not turn off even after the car is shut off. Nor will it activate It stays on bright all the time.
jasen1 is offline   Reply With Quote Quick reply to this message
Old 03-01-2012, 11:13 PM   #8 (permalink)
Member
 
Join Date: Nov 2010
Posts: 92
Gary0100
Default

Quote:
Originally Posted by jasen1 View Post
most likely you have a bad ballast that sometime fires and sometimes doesn't. Turn them off.. count to 5 and turn them back on. That should do it. If not, cycle them again.
cycle them again?
Gary0100 is offline   Reply With Quote Quick reply to this message
Old 03-04-2012, 12:24 AM   #9 (permalink)
Senior Member
 
CHiSEEN's Avatar
 
Join Date: Nov 2011
Location: Queens, New York
Drives 2012 Hyundai Sonata Limited 2.0T
Posts: 438
CHiSEEN is an unknown quantity at this point
Default

you might also want to check the fuse on the relay harness to see if it didn't just blow, that would be easily replaceable. You can tell by putting it through an ohmmeter or just replacing it with a new fuse if you don't have an ohmmeter. I think it should be like a 20 amp fuse, your local auto shop should sell them pretty cheap. I doubt it would be a ballast issue if both of them failed at the same time unless something affected both ballasts to make them both malfunction.


Going to the dealer for this problem is defiantly a no go since the headlights are modded.
__________________
Harbor Gray
2012 Hyundai Sonata 2.0T Limited
XS 6000K HID Low Beams | PIAA 2500K Plasma Ion Yellow Fog Lights | SR LED DRL | MOBIS Tail Lights | VLED 5000K Reverse Lights | PLED 8000K LED Interior Lighting | LED Cupholder Mod | SR Black Fog Light Molding | MOBIS Chrome Lower Door Molding | SR Rear Diffuser - Type 2 | 35% Tint All Around
CHiSEEN is offline   Reply With Quote Quick reply to this message
Old 03-04-2012, 11:00 AM   #10 (permalink)
Senior Member
 
jasen1's Avatar
 
Join Date: Jan 2011
Location: Edmonton Alberta
Posts: 2,073
jasen1 is an unknown quantity at this point
Default

Quote:
Originally Posted by Gary0100 View Post
cycle them again?
Turn them off then on. You checked all your connections and made sure all the wires are still connected first right?
jasen1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:50 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.