Brake switch/sensor - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-15-2011, 10:02 PM   #1 (permalink)
Junior Member
 
Join Date: Oct 2010
Posts: 9
elokito
Default Brake switch/sensor

Hyundai is well aware of the problem of the the brake switch/sensor under the brake pedal dying, they made the version 2.0 of this switch/sensor and already started sending it to Hyundai dealers. This is covered under warranty but will only get replaced if asked.

the problem is the switch dies out because of humidity, I'm on my third one (version 1.0) I'm waiting for the new ones to arrive given the version 2.0 of this switch went out very quick in my country.

the switch is in charge of sending a signal to the car that the brake is being pressed so that you can change gears, if you are stuck simply remove the cap and press it with something then you can change gears.

I as well as others was really tired of having to press the shift release with something every time so i just stuck a scissor on it until the new sensor arrives (which was kinda of what the dealer here offered me to do while the new sensor arrived, to modify something in the brake which would've given the same effect as sticking a scissor on the shift release).

I recommend exchanging your switch/sensor asap
Attached Images
File Type: jpg IMG-20110914-00044.jpg (160.2 KB, 107 views)
elokito is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-30-2011, 11:23 AM   #2 (permalink)
Member
 
Join Date: Apr 2010
Location: Philadelphia, PA
Posts: 48
frank1203
Default

Wow, can't believe you just posted this. I have been having issues for the last 6-8 months on my 2010 Tucson where the car would not start. In other words, I crank the key and everything lights fine, but engine not cranking - no nothing.. The "P" for Park or "N" for Neutral would not even illuminate on the dash. Eventually, it started, especially when I moved the shifter to neutral. It was sporadic and the dealer could not locate the issue aftyer repeated visits. Then today... I brought the car in for maintenance and the dealer saw Code C1513 which showed a faulty Brake Switch. It was replaced today and he said that was my "starting" problem. Does that make sense? Is that what you experienced? Not sure how faulty brake switch control would be controlling that starting issue I described but who knows... Please see a prior post of mine whare I explained the issue in detail. Thanks for your input!

Last edited by frank1203; 09-30-2011 at 11:25 AM.
frank1203 is offline   Reply With Quote Quick reply to this message
Old 09-30-2011, 12:27 PM   #3 (permalink)
Senior Member
 
MikDee's Avatar
 
Join Date: Apr 2006
Location: Milford, Pa.
Drives 2011 Sportage EX AWD techno orange
Posts: 779
MikDee
Default

Many Thanks for the heads up elokito I'll keep a watch on this. I don't know if this applies, or is a related issue, but I've noticed balky shifting on mine unless my foot is squarely, & firmly on the brake. I see this is an issue over on the Sportage forum as well.
__________________
A few vehicles I've owned, fixed, or modified, & sold, over the years :
http://smg.photobucket.com/user/MikD...91080772125485
MikDee is offline   Reply With Quote Quick reply to this message
Old 10-01-2011, 08:13 AM   #4 (permalink)
Junior Member
 
Join Date: Oct 2010
Posts: 9
elokito
Default

@frank1203, my tucson showed the shift on the dash just fine, but it could've been the the brake switch on your tucson that died who knows, just make sure you got your brake switch replaced with the version 2.0 I will post pics next week of each of the versions.

@MikDee you mean shifting gears when the tucson is stopped? like from parking to D and D to parking, reverse etc? or do you mean shifting when you are driving, if its when the car is stopped then obviously its the brake switch, and I had a problem with my tucson not shifting gears (on automatic) with difficulty and also had it replaced.
elokito is offline   Reply With Quote Quick reply to this message
Old 02-29-2012, 07:04 AM   #5 (permalink)
Junior Member
 
Join Date: Feb 2012
Location: Alice Springs , NT , Australia
IX35 Highlander
Posts: 1
hosa85 is an unknown quantity at this point
Default

I have also just had this issue stopping me from starting the car , quite annoying . They have replaced the switch but whilst doing that , "some how" they have unplugged or damaged something and now my reverse camera does not work .

I have been advised if anyone has starting issues due to the switch not working just hold down the start button for 10 seconds and it will override the stop switch and start
hosa85 is offline   Reply With Quote Quick reply to this message
Old 07-14-2013, 01:51 PM   #6 (permalink)
Junior Member
 
Join Date: Jul 2013
Location: Putnam/CT/Northeast
Drives Tucson
Posts: 1
dzlmick is an unknown quantity at this point
Default

I've got this same issue on my 2010 Tucson. does anyone know if this is a recalled part that hyundai will fix at a service center, or if I can just change out the switch myself?
dzlmick is offline   Reply With Quote Quick reply to this message
Old 07-14-2013, 05:33 PM   #7 (permalink)
Member
 
Paulas2's Avatar
 
Join Date: Mar 2011
Location: Queensland, Australia
Drives Hyundai ix35 LM Highlander, 2010, diesel automatic.
Posts: 48
Paulas2
Default

Why replace it yourself when the vehicle is still under warranty?
Paulas2 is offline   Reply With Quote Quick reply to this message
Old 07-14-2013, 11:41 PM   #8 (permalink)
Senior Member
 
MikDee's Avatar
 
Join Date: Apr 2006
Location: Milford, Pa.
Drives 2011 Sportage EX AWD techno orange
Posts: 779
MikDee
Default

My 2011 Sportage EX goes in Tues. for this issue! The lights have been going on, & off for a few days now, with balky shifting.

Apparently there is no recall for the 2011 Sportage, or 2011 Tucson, but I've got news for Kia! Mine, & 1/2 dozen others are having these same issues with their 2011 Sportages.
__________________
A few vehicles I've owned, fixed, or modified, & sold, over the years :
http://smg.photobucket.com/user/MikD...91080772125485
MikDee is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:54 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.