2004 2.4l Code P0401 Help - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 02-17-2011, 05:32 PM   #1 (permalink)
Junior Member
 
Join Date: Jan 2011
Posts: 7
HeliumGGA
Default

EGR insufficient flow. EGR valve was pretty bad looking seemed a bit sticky when opened so I replaced it along with gasket. reset the computer but check engine light came back on code p0401 again. I know you can test by pinching the yellow striped hose at the throttle body to see if the solenoid is bad. The engine will stumble a bit when you pinch it closed, or so I am told. However when I pinch the hose, nothing happens. I do notice that the car does idle kind of roughly. Anyone have any insight into this issue? Thanks in advance.
HeliumGGA is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-02-2012, 07:52 PM   #2 (permalink)
Junior Member
 
Join Date: May 2012
Location: Indianapolis
2003 Hyundai Santa Fe 2.4l 4cyl 2wd 140k+ miles.
Posts: 2
Danc83 is an unknown quantity at this point
Default

Hi, I am having the exact same problem. No stall or shudder when I pinch the yellow hose. I've also read this article people have posted on here before: http://www.myhyundaiforums.com/TSB/xml/06-36-006.swf

It's difficult to test the vacuum when the hoses are so corroded they will break when removed so I'm shopping for replacement hoses now and I will just switch them out and check the metal pipes for blockages. Since my egr valve is new I am looking at buying new vacuum valve and solenoid. But where to buy the hoses and know if the solenoid/vacuum valves are right for my 2003 4cyl?
Danc83 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:50 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.