Brake Light/ Turn Signal Problem - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 08-24-2010, 01:26 AM   #1 (permalink)
Junior Member
 
Join Date: Aug 2010
Posts: 2
gumby25
Default

Ok heres the deal. My right turn signal works fine unless the brake is pressed. The left works fine no problems. If the flashers are on and i press the brake the flashers stop on both sides. The brake lights work fine on both sides. Ive checked all the bulbs on both sides, front and back, and everything is working fine. Its only a problem when im trying to use my right turn signal when the brake pedal is pressed the turn signal stops flashing and just lights up.

If anyone has had this same issue or might know what it would be itd be a huge help. I was thinking maybe the turn signal relay or maybe the brake switch...
gumby25 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-24-2010, 04:09 AM   #2 (permalink)
ADMINISTRATOR
 
Montego's Avatar
 
Join Date: Jan 2005
Location: South East England
Drives 2 XG's (2001 & 2002). Range Rover & Ford Escort Van
Posts: 12,090
Montego has disabled reputation
Garage
Default

welcome to the forums

the problem you have is caused by a bad earth/ground connection on the back light. check the rear right light bulb holder assembly and make sure the black wire (ground connection), this is where is making a good contact, this is where the problem lies
__________________


MONTEGO

""""""""""""""""""""""""



Montego is offline   Reply With Quote Quick reply to this message
Old 08-24-2010, 07:44 AM   #3 (permalink)
Member
 
Join Date: Feb 2010
Location: libya
Santafe 2004 2.4l Automatic
Posts: 87
snake52
Default


Hello


I am having the same problem but with the stop light, first one on the taillight bulbs stop working i change it works for a while but then it burned again if i change it works fine after pressing the brake pedal for sometime the bulb will get burned can you help us by showing us a picture where is the black wire is


thank you
[attachment=19956:92620.jpg]
Attached Images
File Type: jpg 92620.jpg (236.3 KB, 4 views)
snake52 is offline   Reply With Quote Quick reply to this message
Old 08-24-2010, 03:46 PM   #4 (permalink)
Junior Member
 
Join Date: Aug 2010
Posts: 2
gumby25
Default

The black wires look good as far as i can see. No cracks, serious bends, fraying. Should the bulb housings be replaced? Even with all the bulbs pulled out of the right(bad) and the flashers on, when i put on the brakes the flashers stop.
gumby25 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:37 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.