Transmission Going Into Fail-safe Mode - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-15-2005, 05:50 AM   #1 (permalink)
Junior Member
 
Join Date: Dec 2005
Posts: 3
gajjitt
Default

Hi all,

I wonder if anyone can help me here. My Sonata year 2000, has a frustrating problem in that the car will drive for some time (a few days) then suddenly it will shudder and the revs go up. At that point the auto trans is stuck in 3rd, heavy acceleration will not cause it to go to 2nd or 1st, and it will never go into 4th. If you stop and restart the car is fine for a while again.

Car is going into the dealer on Monday to have the codes read from the computer. The engine warning indicator never lights up.

Has anyone else had this, and what did they diagnose the problem as? Is it likely to be serious, the car drives very nicely until it happens. Wondering if this is something that happens and whether there is often a simple explanation which can be fixed quickly.

Any help will be welcome, I will tell you the outcome after the dealer has looked at it on Monday.

It has to start happening when my folks are about to embark on a visit from the UK to Australia for 3 weeks doesn't it?

Have a good weekend.

Thanks Paul
gajjitt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-15-2005, 09:27 AM   #2 (permalink)
Senior Member
 
Luxury's Avatar
 
Join Date: Oct 2005
Posts: 356
Luxury
Default

I haven't heard of this problem on an 06 Sonata (yet), but it is somewhat common on the Cadillac Catera I used to drive. It is most likely an electrical problem, since it is intermittant and returns to normal operation. If it was a mechanical problem, it would not reset after turning the car off. It will probably be an easy diagnosis and fix, such as replacing a control module. Even though the CEL never came on, there are probably codes stored somewhere. Good luck and let us know how it turns out.
Luxury is offline   Reply With Quote Quick reply to this message
Old 12-16-2005, 01:13 PM   #3 (permalink)
madderhatter
Guest
 
Posts: n/a
Default

I think this needs to be moved to a different forum - his car is a 2000.
  Reply With Quote Quick reply to this message
Old 12-21-2005, 11:31 AM   #4 (permalink)
Junior Member
 
Join Date: Dec 2005
Posts: 3
gajjitt
Default

Hi my car is a 2000 Sonata.

FYI the dealer checked the codes and it reported that the input and output speed sensors were faulty. Some AU$700 later it's fixed and working!! A little painful in the pocket but happy with the outcome, the car is smooth and responsive again.

Hope this helps anyone else with a similar problem.

Cheers Paul
gajjitt is offline   Reply With Quote Quick reply to this message
Old 12-21-2005, 11:33 AM   #5 (permalink)
Junior Member
 
Join Date: Dec 2005
Posts: 3
gajjitt
Default

Please tell me why the "Sonata" forum is the wrong place for a year 2000 Sonata?

Thanks Paul
gajjitt is offline   Reply With Quote Quick reply to this message
Old 12-30-2005, 07:45 AM   #6 (permalink)
Junior Member
 
Join Date: Dec 2005
Posts: 1
Madmax
Default

Greg here

I have a 1999 Sonata and the output speed sensors has gone faulty x2

any idea way this is happening.

Why is this sensor so costly.
Madmax is offline   Reply With Quote Quick reply to this message
Old 03-04-2006, 05:47 PM   #7 (permalink)
Junior Member
 
Join Date: Mar 2006
Posts: 9
TAKEMYEXWIFE
Default

iM JUST GONNA SAY CHECK FOR AN OUTPUT SENSER ON THE TRANSMISSION. sOUNDS LIKE THAT. iF ITS GOT ONE THATS PROBABLY IT. ESP IF SPEEDOMETERE PROBLEMS ACCOMPANY IT. ALSO CHECK FOR AN INPUT SENSOR. ZGOOD LUCK
TAKEMYEXWIFE is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:48 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.