No Heat Even With New Thermostat - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-12-2004, 12:02 PM   #1 (permalink)
Junior Member
 
Join Date: Dec 2004
Posts: 4
lmpulaski
Default

i hope someone could help me with this strange problem.
my car has a heater problem.
when the heater is on the heat will diminish,and the temperature needle plummets all the way to cold.
when the heater is off the needle functions normally?
so... i'm getting no heat,and the temp needle is whacked.
can anyone help me out ?
i have a 2001 hyundai tiburon.



thank you.
lmpulaski is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-12-2004, 02:32 PM   #2 (permalink)
Senior Member
 
duke's Avatar
 
Join Date: Oct 2004
Posts: 1,850
duke
Default

Well, indeed a strange phenomena. Are you sure, that a correct thermostat is installed ?? who installed it, and what kind of thermostat is it ??
duke is offline   Reply With Quote Quick reply to this message
Old 12-12-2004, 07:49 PM   #3 (permalink)
Junior Member
 
Join Date: Dec 2004
Posts: 4
lmpulaski
Default

yes,it was the correct one.
how would i know if it wasn't?
i had the guy in the auto parts store look it up and give it to me.
i'm hoping that this isn't a serious problem though.
thanks for the reply.
lmpulaski is offline   Reply With Quote Quick reply to this message
Old 12-13-2004, 11:38 AM   #4 (permalink)
Senior Member
 
duke's Avatar
 
Join Date: Oct 2004
Posts: 1,850
duke
Thumbs up

Quote:
Originally posted by lmpulaski@Dec 12 2004, 04:49 PM
[b]yes,it was the correct one.
how would i know if it wasn't?
i had the guy in the auto parts store look it up and give it to me.
i'm hoping that this isn't a serious problem though.
thanks for the reply.*
[snapback]3585[/snapback]

??????????DID THE NEW ONE LOOK THE SAME AS THE OLD ONE????????
the thermostat is in the return hose, and is a double regulating one, it mixes the cold colant from the rad with the colant circulating in the engine.
duke is offline   Reply With Quote Quick reply to this message
Old 12-15-2005, 11:44 AM   #5 (permalink)
Junior Member
 
Join Date: Aug 2005
Posts: 24
vduhr
Default

Quote:
Originally posted by duke@Dec 13 2004, 10:38 AM
[b]??????????DID THE NEW ONE LOOK THE SAME AS THE OLD ONE????????
the thermostat is in the return hose, and is a double regulating one, it mixes the cold colant from the rad with the colant circulating in the engine.
[snapback]3625[/snapback]
I am having the same problem in my 01 Elantra. I have read many suggestions on this board and am going to go to the dealer to get another thermostat, as I too got one from a parts store. As far as the location of the thermostat, I thought it was in a weird place (i.e., at the end of the the return hose (from the radiator to the engine), rather than the upper radiator hose (from the engine to the radiator). Is that what you are saying? And is this supposed to be the correct location for an 01 Elantra too? If so, what temp thermostat is supposed to be installed? I had put in a 180 degree therm. If the cool liquid is mixed with the warm, what is the proper open temp of the thermostat?
vduhr is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:43 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.