esp light issues - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-01-2012, 03:24 PM   #1 (permalink)
Guest
 
Join Date: Feb 2012
Location: leighton buzzard U.K
SANTA FE 2.2 LTD
Posts: 69
xxxxxxxxdarklordmick is an unknown quantity at this point
Angry esp light issues

hi all..
i have a 2.2dci santa fe uk spec...and since i have owned it (6months) the esp light keeps coming on...whilst in warranty hyundai replaced brake switch, g lateral sensor and thats about it...its the same fault code every time...lateral G sensor

its been in at least 6 times and still not fixed.....they last blamed my 20" rims and asked if i could get some santa fe 18" alloys....which after much searching the net managed to source at set at great expense...ive just done a full geometry on the car and yet the light still comes on...it goes off for a bit if you turn the engine off and back on again....sometimes anyway...

now out of warranty hyundai are wiping their hands of it...which i feel is unjust as it was not fixed in warranty so as far as im concerned they should still be liable for it...

anyway...does anyone know when the esp light comes on what exactly is the esp controlling/monitoring ...what ever it is the fault is not with the wheels..
i really have had enough of this and now thinking of chopping it in already and get something else...im very disappointed in hyundai's attitude to this fault...

can someone point me in the right direction

its getting more frequent nowadays
xxxxxxxxdarklordmick is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-01-2012, 10:28 PM   #2 (permalink)
Guest
 
Join Date: Feb 2012
Location: leighton buzzard U.K
SANTA FE 2.2 LTD
Posts: 69
xxxxxxxxdarklordmick is an unknown quantity at this point
Default

by the way...the "esp off" is the only light that shows on my dash board and it doesnt matter what speed im doing, driving in a straight line or turning a corner...yesterday it was on without even moving the car....
this is really doing my head in..
id love to get to the bottom of this...
xxxxxxxxdarklordmick is offline   Reply With Quote Quick reply to this message
Old 11-02-2012, 07:51 AM   #3 (permalink)
Senior Member
 
Join Date: Apr 2011
Posts: 245
SantaFeFan is an unknown quantity at this point
Default

I had mine go on yesterday for the second time in 3 months... Now it is off. I think I will take it in next week to the dealer.
SantaFeFan is online now   Reply With Quote Quick reply to this message
Old 11-02-2012, 09:05 AM   #4 (permalink)
Guest
 
Join Date: Feb 2012
Location: leighton buzzard U.K
SANTA FE 2.2 LTD
Posts: 69
xxxxxxxxdarklordmick is an unknown quantity at this point
Default

Quote:
Originally Posted by SantaFeFan View Post
I had mine go on yesterday for the second time in 3 months... Now it is off. I think I will take it in next week to the dealer.
It seems to be a common thing by the looks of it.. I feel there is too many systems attached to this ESP light...
Let us know what they say on yours.. Be interesting to see if its the same thing as mine... G lateral sensor which has been replaced
xxxxxxxxdarklordmick is offline   Reply With Quote Quick reply to this message
Old 11-02-2012, 09:21 AM   #5 (permalink)
Senior Member
 
Join Date: Jan 2010
Location: England
Posts: 2,230
Ruperts Trooper is an unknown quantity at this point
Default

If there's ANY issue with the ABS system, like dirty sensors or loose connections, then that will disable the ESP and put the light on.
__________________
RT

2011 Santa Fe 2.2CRDi Premium 7-seat automatic (often being tailgated by a 1500 kg caravan)
Ruperts Trooper is online now   Reply With Quote Quick reply to this message
Old 11-02-2012, 09:28 AM   #6 (permalink)
Guest
 
Join Date: Feb 2012
Location: leighton buzzard U.K
SANTA FE 2.2 LTD
Posts: 69
xxxxxxxxdarklordmick is an unknown quantity at this point
Default

But wouldn't it show up as a fault code on the ecu.. As far as I know they said its not sensor as no fault code shown..
xxxxxxxxdarklordmick is offline   Reply With Quote Quick reply to this message
Old 11-02-2012, 11:01 AM   #7 (permalink)
Senior Member
 
Join Date: Apr 2011
Posts: 245
SantaFeFan is an unknown quantity at this point
Default

Quote:
Originally Posted by SantaFeFan View Post
I had mine go on yesterday for the second time in 3 months... Now it is off. I think I will take it in next week to the dealer.
What's strange and maybe a coincidence, the last few times, it came on within a day or so after a full car wash... Loosen brake dust, dirty sensor? I will let you guys know next week after I take it in.
SantaFeFan is online now   Reply With Quote Quick reply to this message
Old 11-05-2012, 11:39 AM   #8 (permalink)
Senior Member
 
Join Date: Apr 2011
Posts: 245
SantaFeFan is an unknown quantity at this point
Default

Just got back from the dealer... They replaced the "stop lamp switch" and updated the ECU...
SantaFeFan is online now   Reply With Quote Quick reply to this message
Old 11-05-2012, 12:29 PM   #9 (permalink)
Guest
 
Join Date: Feb 2012
Location: leighton buzzard U.K
SANTA FE 2.2 LTD
Posts: 69
xxxxxxxxdarklordmick is an unknown quantity at this point
Default

Well I have already has that done.. It was the 1st thing they changed.. Not sure if I have has an ecu update but mine is back at the dealers today and they will check it all out.. I'll let you lot know what they say.. They have had all day today
xxxxxxxxdarklordmick is offline   Reply With Quote Quick reply to this message
Old 11-05-2012, 06:05 PM   #10 (permalink)
Senior Member
 
Join Date: Apr 2011
Posts: 245
SantaFeFan is an unknown quantity at this point
Default

They only updated the ECU because I asked them to... Did have them change the oil/filter and I had to tighten the cap a little because I noticed a little oil seeping. Whats new. Lol...
SantaFeFan is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:18 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.