2002 Hyundai Elantra Acceleration Problem - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-02-2008, 11:01 AM   #1 (permalink)
Junior Member
 
Join Date: Dec 2008
Location: Valdosta
Posts: 1
jeffbrown16
Default

Hello,

I drive a 2002 Hyundai elantra gls. I recently drove to mississippi to visit family and also made the drive back. about 3 hours into the drive, my car begins to shake like never before at around 70 mph. i took it off cruise and let off the gas and the shaking went away. as soon as i pressed the pedal to accelerate, the shaking comes back and will not stop. i was 6 hours away from school so i had to drive it out the rest of the way. i left the cruise on 65mph and randomly the engine would shake uncontrollably but it would go away after a few minutes and the car would be smooth sailing again. i filled up at a kroger before i left MS and my grandfather says there may be water in the gas. i stopped at a truck stop and bought stp gas cleaner and put it into the tank. when i drive at speeds less than 60 mph the shaking is not there. i have had minor shaking in the front end before when i am traveling 75 mph but i know it's due to the alignment and brake balance. this is an engine problem and every time i accelerate past 60 mph i can feel the entire front end going nuts. please post anything you can to help. any advice will be greatly appreciated. thanks for your time.
Jeff
jeffbrown16 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-02-2008, 12:15 PM   #2 (permalink)
Senior Member
 
byronguidry3732's Avatar
 
Join Date: Sep 2006
Location: Westminster, CO
2010 Genesis, 2009 Kia Sorento, 2008 Sonata, 2004 Jeep Cherokee
Posts: 2,927
byronguidry3732 is an unknown quantity at this point
Default

Dear Jeff,

You have confused the issue with the possible wheel alignment problem, so you may have two things happening.
1. Water in the gas: this is highly likely. The Elantra engine can accomodate some mild spark misfiring, and this probably becomes severe at higher rpm. You can test this theory by noting the speed, rpm and gear you are in when the car starts to buck violently. You did say over 70 mph, but the rpm is more important.
2. Now that you have the rpm figure, shift to a lower gear like third, and drive the car under load to the SAME rpm in a lower gear. This should be a lower speed, say 45 mph, but the engine bucking should be the same. If yes, get three cans of HEET gas deicer/water remover. You will have problems until the bad gasoline is used up.

When was your last timing belt change? We have assumed the cause-and-effect was your fill up in MS. Unless you know that your belt was changed at 60k miles and 120k miles, remove your upper timing cover, have a helper rotate the engine crankshaft bolt clockwise slowly, and inspect for broken/missing teeth on the timing belt, and inspect your static timing...line up the crankshaft timing mark, and verify that the two camshafts are also on the timing mark.

If your engine does NOT buck at the same rpm under load in all gears but only 70 mph, then your problem is independent of engine rpm...and likely not engine related. Get the wheel alignment and tire balance. If your front brake rotors are vibrating, get them inspected and turned at a brake shop.

P>S> you did not mention a Check Engine Light, but misfiring will cause a CEL code.

Byron
__________________
Where's my bailout?
byronguidry3732 is offline   Reply With Quote Quick reply to this message
Old 01-02-2009, 06:55 AM   #3 (permalink)
Member
 
Join Date: Oct 2008
Posts: 31
badkid32
Default

My car acts in a similar way, but I know for sure that it's not an allighment / wheel balence issue. The car will vibrate abnormally when given too much gas, even in park / neutral. While driving, it has issues getting over about 2k rpm, but once it gets above it, smooths out. The problem is speed independant. Also, it will cough at idle, but not very often. There is no CEL light.
badkid32 is offline   Reply With Quote Quick reply to this message
Old 01-02-2009, 03:34 PM   #4 (permalink)
Senior Member
 
byronguidry3732's Avatar
 
Join Date: Sep 2006
Location: Westminster, CO
2010 Genesis, 2009 Kia Sorento, 2008 Sonata, 2004 Jeep Cherokee
Posts: 2,927
byronguidry3732 is an unknown quantity at this point
Default

Dear badkid,

In your case we do not have enough information. Please check one thing and verify one thing.

1) When was you air filter last changed? Can you check it now?
2) When was your last professional fuel injector cleaning service?

Byron
__________________
Where's my bailout?
byronguidry3732 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:45 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.