buying a elantra 2002 - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-24-2013, 09:45 AM   #1 (permalink)
Junior Member
 
Join Date: Sep 2013
Location: Willemstad
-
Posts: 1
magijs is an unknown quantity at this point
Default buying a elantra 2002

hi,

I'm currently living in Willemstad, Curacao and was looking for a new car. Yesterdag 1 found a Hyundai Elantra 2.0 from 2002, a white one.

So i went there to look at it and must say its a pretty nice car, looks good, drives good. Everyting works, the electric windows, he starts immidiately and it runs really nice. Also its an automatic and it shifts smoothly!!

There are only 2 things that i don't like, for 1 the ac isn't blowing cold air but i think thats a small problem and i only have to fill it up (right?)

The other thing is the mileage, currently its 235000 km so about 150000 miles and i really have no idea if thats a problem for a Elantra or not. If i drive in it, it rides very smooth but still its a lot of miles.....

I was searching the web for stories or review but i coudn't found 1 with a high mileage so i really don't know if its smart to buy this car or not

I hope you guys can give me some advice and sorry for the bad english
magijs is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-24-2013, 09:51 AM   #2 (permalink)
Junior Member
 
Join Date: Sep 2013
Location: Massachusetts
2001 Accent, 2002 Elantra
Posts: 13
ShadeTM is an unknown quantity at this point
Default

For the AC you need to get it checkout by a professional who can do a a vaccum test to see if there is a leak. If there is a leak it will cost you some serious money to fix it depending on the part leaking. AC is not suppose to lose the R134A unless there is a leak. They can also test for leaks using a UV dye..

For the high mileage, get a compression test done. If it is within range you should be ok. Check if the timing belt was replaced. If not you will need to replace timing belt and water pump at the same time. It is cheaper in labor cost that way.
__________________
Shade Tree Mechanic
ShadeTM is offline   Reply With Quote Quick reply to this message
Old 09-24-2013, 06:49 PM   #3 (permalink)
senior member
 
Em-squared's Avatar
 
Join Date: Aug 2011
Location: near Portland, OR
2012 Nissan Leaf SL; 2012 Nissan X-Terra Pro-4X
Posts: 6,837
Em-squared is an unknown quantity at this point
Garage
Default

magijs.
__________________
Fashionista.



Former driver of 2011 Elantra Limited no tech, and 2010 Genesis Coupe 3.8 Track
Em-squared is offline   Reply With Quote Quick reply to this message
Old 09-25-2013, 09:01 AM   #4 (permalink)
PLP
Banned
 
Join Date: Jan 2009
Location: Haslett, MI, USA, Earth
2007 KIA Rondo, 2.7 V6, 5 A/T 2009 Hyundai Elantra, 2.0 I4, 5 M/T, sedan, GLS, black pearl
Posts: 998
PLP is an unknown quantity at this point
Default

Quote:
Originally Posted by magijs View Post
There are only 2 things that i don't like, for 1 the ac isn't blowing cold air but i think thats a small problem and i only have to fill it up (right?)
could be, could not be... hard to say. It might be lack of maintenance and after years it leaked out (over ten years with no refills?)
As ShadeTM said - you might want to check it by someone who knows this stuff.
Unless, you can invest in two cans of refrigerant, or tell the seller to refill the A/C and see if it works. Sometimes it is cheaper to refill it once a year than repair some expensive parts.

Quote:
Originally Posted by magijs View Post
The other thing is the mileage, currently its 235000 km so about 150000 miles and i really have no idea if thats a problem for a Elantra or not. If i drive in it, it rides very smooth but still its a lot of miles....
It does not have to be a problem.
If it starts right away that is a good sign. If you see no huge oil leaks, oil cap looks clean (inside) and you do not smell much bad/burned from the engine - you should be good.
Also, check colour of transmission fluid.
Drive the car hard (after it reaches operating temp). See how it shifts at load, how does it accelerate under full throttle. Hit the brakes hard to see if there is no pulling to one side and so on...

Quote:
Originally Posted by magijs View Post
sorry for the bad english
Do not worry about it. You would be surprised how many people here are ESL. Me for example...

Quote:
Originally Posted by ShadeTM View Post
For the high mileage, get a compression test done. If it is within range you should be ok. Check if the timing belt was replaced. If not you will need to replace timing belt and water pump at the same time. It is cheaper in labor cost that way.

One comment here.
Water pump is not a part of TB. Sure, it is safe to replace it, but it is not necessary for the timing belt, which in turn, must be replaced, UNLESS the owner has a prove - a receipt from service stating what belt and when was installed.
Otherwise - do not even look on the belt. It always looks nice.


Compression - that is very important as it is possible that IF the timing belt was recently done it could have snapped before then causing some valves to bent (a little damage).
Therefore, compression test must be performed.
PLP is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:32 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.