2001 Automatic Transmission Shifting Erratically - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 05-14-2011, 01:02 AM   #1 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 6
ghetto3jon
Default

i have a 2001 elantra with 136k. the automatic transmission (which otherwise shifts very smoothly and shows no sign of problems) shifts suddenly and erratically when i'm driving at a constant speed. i'll be traveling along (speed doesn't matter), and it will suddenly downshift, then upshift, then downshift, etc. this started off being very occasional, but now it randomly shifts every 5-10 seconds.

i've changed and checked the fluid, and tried replacing the Input Speed Sensor and the Output Speed sensor...that didn't fix it. it also does not blow a check engine code. i'm convinced there must be a sensor somewhere that is faulty. it really seems as though the transmission is electronically confused.

any help is greatly appreciated.
ghetto3jon is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-14-2011, 04:43 AM   #2 (permalink)
Senior Member
 
jsinton's Avatar
 
Join Date: Jun 2009
Location: Inverness, Florida
'99 Elantra Wagon '03 Kia Sedona
Posts: 4,339
jsinton is an unknown quantity at this point
Default

Did you scan for codes? I would only be speculating to say that the range selector switch can do weird things when it goes bad.
__________________

jsinton is offline   Reply With Quote Quick reply to this message
Old 05-14-2011, 10:18 AM   #3 (permalink)
Senior Member
 
sbr711's Avatar
 
Join Date: Apr 2010
Location: hiding from those who might be looking for me
I dont own Hyundai car, I drive everybody else Hyundai during day
Posts: 8,656
sbr711 is an unknown quantity at this point
Default

You need to access the TCM and see if any codes hiding in there.
__________________
<--- please fill in the 'location' and 'what you drive' boxes on your personal profile page.
This information makes it much easier for other members to answer/comment on your posts.
sbr711 is offline   Reply With Quote Quick reply to this message
Old 05-14-2011, 11:44 AM   #4 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 6
ghetto3jon
Default

so take it to the dealer, basically. bummer.
ghetto3jon is offline   Reply With Quote Quick reply to this message
Old 05-14-2011, 11:47 AM   #5 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 6
ghetto3jon
Default

although maybe i'll try the range selector switch first if it's cheap. do you have a part number? i'm unfamiliar with that part. thanks so much!
ghetto3jon is offline   Reply With Quote Quick reply to this message
Old 05-14-2011, 01:24 PM   #6 (permalink)
Junior Member
 
Join Date: Apr 2011
Posts: 5
jfb777
Default

QUOTE (ghetto3jon @ May 14 2011, 01:02 AM)
Quote:
i have a 2001 elantra with 136k. the automatic transmission (which otherwise shifts very smoothly and shows no sign of problems) shifts suddenly and erratically when i'm driving at a constant speed. i'll be traveling along (speed doesn't matter), and it will suddenly downshift, then upshift, then downshift, etc. this started off being very occasional, but now it randomly shifts every 5-10 seconds.

i've changed and checked the fluid, and tried replacing the Input Speed Sensor and the Output Speed sensor...that didn't fix it. it also does not blow a check engine code. i'm convinced there must be a sensor somewhere that is faulty. it really seems as though the transmission is electronically confused.

any help is greatly appreciated.

sounds like the transmission range sensor to me i had the same problem and it turned out it was that replaced it and it got a lot better and i did the speed sensors as well mine still does the erratic shifting here and there but i havent had the chance to adjust the transmission switch yet be sure to when u change out the sensors to get the codes wiped then drive 50 miles then check for codes again..
jfb777 is offline   Reply With Quote Quick reply to this message
Old 07-20-2012, 10:44 AM   #7 (permalink)
Junior Member
 
Join Date: Jul 2012
Location: 15102
hyundai elantra 01
Posts: 1
danielson3 is an unknown quantity at this point
Default

Have an 01 elantra had the same problem.replaced the TPS throttle position sensor.completely fixed the problem.
danielson3 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:38 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.