2001 Hyundai Elantra - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 06-26-2010, 02:59 PM   #1 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 1
chowderfann
Default

Car just seems like its not getting gas. I took it to a small shop and they said they didn't want anything to do with it. Too many codes. They replaced the Cam Shaft Sensor but still not luck. Also when filled up with gas has trouble starting. Here are the codes he gave me:

PO340: CamShaft Position Sensor.......already replaced still having problems
P1166: Undefined
PO440: Evaporative Emission Control System
UoDoo: Undefined
PO711: Transmission Fluid Temp Sensor circuit performance
P 2300: Undefined

Please help......I know I should take it into the dealership, but I am so cash poor right now.....I work full time and go to school paying for it on my own and I just need some help......My brother is a dodge mechanic and says he can probably replace any part necessary just doesn't have the right scanner I guess to figure out this issue please help.
chowderfann is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-27-2010, 10:23 AM   #2 (permalink)
Senior Member
 
sbr711's Avatar
 
Join Date: Apr 2010
Location: hiding from those who might be looking for me
I dont own Hyundai car, I drive everybody else Hyundai during day
Posts: 8,271
sbr711 is an unknown quantity at this point
Default

QUOTE (ryanfann @ Jun 26 2010, 02:59 PM)
Quote:
Car just seems like its not getting gas. I took it to a small shop and they said they didn't want anything to do with it. Too many codes. They replaced the Cam Shaft Sensor but still not luck. Also when filled up with gas has trouble starting. Here are the codes he gave me:

PO340: CamShaft Position Sensor.......already replaced still having problems
[b]Replaced and still come back.... look at the dowel pin pressed into the intake cam the rotates by the CMP,,, see if the nose of the dowet is ate up.deformed, if so, you will need to replace the intake cam, and if solid follower, adjust the valves via the shims on top of the followers...

P1166: Undefined
[b]Ox B1S1 at limit, possible biased sensor... wait till other stuff is corrected

PO440: Evaporative Emission Control System
[b]Generic EVAP system, could be anything, I like it when an are specific code is stored, cuts diag time..HI-SCAN helps here, as we can force an EVAP test to help with diag as we move along

UoDoo: Undefined
[b]No value, disregard

PO711: Transmission Fluid Temp Sensor circuit performance
[b]As posted for meaning, I would look at Current Data, see if TCM is actually seeing temp... yes, clear it and try again

P 2300: Undefined
[b]No value, disregard

Please help......I know I should take it into the dealership, but I am so cash poor right now.....I work full time and go to school paying for it on my own and I just need some help......My brother is a dodge mechanic and says he can probably replace any part necessary just doesn't have the right scanner I guess to figure out this issue please help.
__________________
<--- please fill in the 'location' and 'what you drive' boxes on your personal profile page.
This information makes it much easier for other members to answer/comment on your posts.
sbr711 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:19 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.