Heater Problems - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-27-2005, 11:48 PM   #1 (permalink)
Member
 
Join Date: Sep 2005
Posts: 88
ride wake 210
Default

hey,

somethin seems to have gone wrong with the blower control switch..the one with all the numbers that controls the speed of the blower or somethin like that..

well my positive battery terminal came off of my battery earlier at my work after my g/f and i got done watchin a movie and it worked fine then..and then it happend again at her house and now i have nuthing for heat..the core is hot because i can fel the heat through the vents but theres no air pushing the heat.

any and all help is greatly appreciated


thanks

sean
ride wake 210 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-28-2005, 01:28 PM   #2 (permalink)
ADMINISTRATOR
 
Montego's Avatar
 
Join Date: Jan 2005
Location: South East England
Drives 2 XG's (2001 & 2002) & Ford Escort Van
Posts: 12,378
Montego has disabled reputation
Garage
Default

you will need to check whether you have got power going to the blower motor itself, use a meter or test light to determin this, this will rule out a faulty motor and/or switch, another possibility is the resistor which controls the blower speed
__________________


MONTEGO

""""""""""""""""""""""""



Montego is offline   Reply With Quote Quick reply to this message
Old 11-28-2005, 04:50 PM   #3 (permalink)
Senior Member
 
Join Date: Jan 2005
Posts: 227
saugen48
Send a message via Yahoo to saugen48
Default

Under the engine bonnet (mine is just behind the battery) is a fuse/relay box. According to the online pics at hmaservice.com, there is a 30amp blower fuse/relay.
K Blower 30A Pink
Check that out, yours may have blown
saugen48 is offline   Reply With Quote Quick reply to this message
Old 11-28-2005, 07:52 PM   #4 (permalink)
Member
 
Join Date: Sep 2005
Posts: 88
ride wake 210
Default

im not sure wut happend.

its all working fine now besudes a few things

my cruize control button on the dash doesn't turn on anymore and my cruize quit working.

and also the lights for both the dials r out and same for the A/C button and the air flow button..im not sure if the button for the air flow-inside air or outside air- is even working or not


thanks guys
ride wake 210 is offline   Reply With Quote Quick reply to this message
Old 02-22-2006, 03:36 PM   #5 (permalink)
Senior Member
 
Join Date: Feb 2006
Location: Arizona
Posts: 378
Dragonmp5
Send a message via Yahoo to Dragonmp5
Default

If the cruise is not working it's either a loss of vaccum or a bad fuse. Have these checked. The lights are out behind my dials as well but I'm not concerned about it just yet.
Dragonmp5 is offline   Reply With Quote Quick reply to this message
Old 02-22-2006, 09:49 PM   #6 (permalink)
Member
 
Join Date: Sep 2005
Posts: 88
ride wake 210
Default

this is so old. i fixed everything on my own.
ride wake 210 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:29 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.