P0335 Crankshaft Position Sensor - 2000 Elantra - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-18-2010, 02:08 AM   #1 (permalink)
Junior Member
 
Join Date: Jan 2009
Posts: 2
2000ElantraMatt
Default

So I have an error code: P0335 Crankshaft Position Sensor A Malfunction.

Let me start from the beginning . . .

Okay, so a few weeks ago, I am pulling my 2000 Elantra (under 80,000 miles on it!) into my work's parking garage, after my daily 10 minute highway drive to work, and my car stops running as I am idling to flash my badge to get into the garage. Weird. It starts back up on the second attempt, and than shuts down again after backing into a parking spot that I found on the 4th floor of the parking garage. Very weird! I was very close to running on no gas that morning, but I felt like I knew my car, and I didn't anticipate a problem. Anyway, it seemed to happen when I was idling. I don't know if that was gas-related, and purely coincidental, but I thought I would mention it this here. Since this did not happen again after filling my gas tank, I dismissed it as nothing.


Startled by the idea of car trouble, I figured that I should check all my fluids to make sure my car was fine otherwise. My engine always leaked a little bit of oil from the gasket seal--no big deal--I just put a little oil in every once and a while. So, here I am, about to put a little more oil in (w-30 to add to the existing w-40, as it is a little thicker and should not leak as fast), when I take off my oil cap, and find a big, yellow, boogerish glob under the oil cap, and some inside my engine too where I can see in. I was freaked out! After reading what I found on the internet about this phenomenon referred as engine condensation, and being as though there was no white/yellowish spots on my dipstick, my concerns were put at ease. That is, until the other night, when my car would not start at all!

It definitely does not sound like a battery problem (I replaced the battery a few years back, anyway). After like the 5th attempt at starting it, it finally started after I held the key turned for what felt like a good minute. With that eventual start came the "Check Engine" light, so I drove it a few minutes back to my house, where it still sits.

My brother came by and tested the "check engine" light, and came up with the aforementioned P0335 error number.
What do you guys think? Do you suspect any coincidences, or does everything add up?

It seems like I have enough oil in my engine, with the amount coming almost right up to the "F" on the dipstick. I've had plenty of gas in the car, and did not experience a shut down since those couple times at the parking garage about a week and a half ago.

I am trying to approach this situation as cheaply as possible. Should I just order a new crankshaft position sensor and start from there? Or does this type of error, and accompanying experience, dictate that I should check something else first? Oh yeah, should mention that I checked underneath the radiator cap to see if there was any white/yellowish buildup there, and there was none (I read online that there might be some yellow goop under the radiator cap if coolant had gotten into the engine and mixed with the oil. The same message boards described the yellow goop as condensation from short drives, as well as possibly from mixing oild types/brands--both of which, I have done recently.).

I don't know anything about cars, but am willing to tackle this myself (depending on what it might be). Any helpful diagrams/instructions for a DIY job? What do you guys think?

Thanks a great deal for your time.
Matt
2000ElantraMatt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:40 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.