Electrical Fault? - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 05-08-2011, 09:37 PM   #1 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 2
Bodgey
Default

Hi my 2003 terracan lights wont work(Head lights) parkers do and indicators work,spot lights work, Battery light remains on with parking brake light all the time, Stero cuts in and out as does the 4wd when the brake is applied for only a second.
Speedo stopped working but it started again.
I have disconnected battery cable while car is running and it does not stop so the battery is charging.
While the battery was disconnected and motor still running the parking lights would flicker on and off when removing and putting the cable back to terminal.

Any idea's?
Bodgey is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-10-2011, 11:44 AM   #2 (permalink)
MODERATOR
 
RBURGOSS's Avatar
 
Join Date: Aug 2009
Location: Costa Rica
Drives Terracan CRDi (2004) and Getz 3dr 1.6 sport (2008)
Posts: 1,462
RBURGOSS is an unknown quantity at this point
Default

QUOTE (Bodgey @ May 8 2011, 09:37 PM)
Quote:
Hi my 2003 terracan lights wont work(Head lights) parkers do and indicators work,spot lights work, Battery light remains on with parking brake light all the time, Stero cuts in and out as does the 4wd when the brake is applied for only a second.
Speedo stopped working but it started again.
[b]I have disconnected battery cable while car is running and it does not stop so the battery is charging.

While the battery was disconnected and motor still running the parking lights would flicker on and off when removing and putting the cable back to terminal.

Any idea's?

First, why did you kept the engine running while disconnecting the battery. This is asking for major damage in almost every single electronic component in your terracan.

If power (electricity) is managed ONLY from alternator/regulator without the battery, it means all sorts of voltage changes, transients, spikes and surges will go through every single electric and electronic component in the vehicle. If the engine still starts and something electric still works normal, I say you were lucky.

As for the strange behavior, I suspect some major wire harness got pinched, unplugged or damaged. This is especially notorius when you get "intermittent" problems (stereo cuts in and out).

I know this is a real pain in your behind, and I strongly suggest taking the car to a knowledgable auto/electric shop, so they can diagnose what is going on. This will probably not be fast and neither cheap, as this sort of damages is like doing a witch hunt while blindfolded.

Let us know

Robert B.
__________________
Robert B.

Don't forget to participate and vote in the February 2013 ROTM thread at http://www.hyundai-forums.com/249-ri...2013-rotm.html
RBURGOSS is offline   Reply With Quote Quick reply to this message
Old 05-23-2011, 05:03 AM   #3 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 2
Bodgey
Default

QUOTE (Robert B. @ May 10 2011, 10:44 AM)
Quote:
First, why did you kept the engine running while disconnecting the battery. This is asking for major damage in almost every single electronic component in your terracan.

If power (electricity) is managed ONLY from alternator/regulator without the battery, it means all sorts of voltage changes, transients, spikes and surges will go through every single electric and electronic component in the vehicle. If the engine still starts and something electric still works normal, I say you were lucky.

As for the strange behavior, I suspect some major wire harness got pinched, unplugged or damaged. This is especially notorius when you get "intermittent" problems (stereo cuts in and out).

I know this is a real pain in your behind, and I strongly suggest taking the car to a knowledgable auto/electric shop, so they can diagnose what is going on. This will probably not be fast and neither cheap, as this sort of damages is like doing a witch hunt while blindfolded.

Let us know

Robert B.

It was the alternator, Repaired and running ALMOST fine.

Light bulbs had blown due to the surge from the regulator within the alternator resulting in more money to replace bulbs.
Stereo and other issues has been resolved.

As for disconnecting battery whilst engine running, It is the most and only way of telling if alternator has died without the required tools to check it.
Cars can run with out the battery so long as your not running lights or other power sucking devices.

Thank you for your input it was much appreciated.

P.S Its a real hassle to remove your alternator, It took me a good 2hrs you have to remove radiator with all the housings ect ect.
Not something ill be doing anytime soon again.

Bodgey is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:03 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.