New Poster/overheating Problem - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 10-08-2007, 03:30 PM   #1 (permalink)
Junior Member
 
Join Date: Oct 2007
Posts: 2
Steve Walters
Default

Hello to All
I am new to the Forum and have a 1998 3.0 v6. I bought it in march this year, its from Germany and was owned by a Doctor and has only covered 60,00 kms. I love it.
I do however have a problem.....I was driving through Germany en route to Bulgaria when it started to overheat, it was taken by the AA to a garage there who replaced the head gasket, which had gone and skimmed the head and did all the neccessary stuff like replacing the Thermostat,cam chain and water pump, but it is still overheating and had to be towed back to England.. the German garage said that they did not really know what was wrong and good luck!.....
i really dont know what to do next. has anyone got any ideas on what the problem could be. I have had a quote for a replacement engine, but I feel this ought to be a last resort really.
i have read somewhere that it is crucial to put the correct coolant in........I topped up with water just before i caught the eurostar, it ran for about 600 kms before the overheating started and was wondering if this had anything to do with it...
..i would be grateful for any advice or if anyone can recommend a specialist on these vehicles in the UK.
thanks....Steve
Steve Walters is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-09-2007, 06:26 AM   #2 (permalink)
Senior Member
 
will's Avatar
 
Join Date: Dec 2004
Posts: 1,000
will
Default

will is offline   Reply With Quote Quick reply to this message
Old 10-13-2007, 02:06 AM   #3 (permalink)
Junior Member
 
Join Date: Oct 2007
Posts: 1
fredkairuz
Default

hi..am a new member with a 2007 Hyundai elantra 4 door sedan. just went to Mazzei Hyundai dealer for change oil/tire rotation and odometer/speedometer calibration. Personnel very accomodating and place look very classy. Dealer situated in Pittsburg/Antioch..Sommersville rd..and hellow to everyone
fred
fredkairuz is offline   Reply With Quote Quick reply to this message
Old 10-13-2007, 11:52 AM   #4 (permalink)
Member
 
Join Date: Jun 2006
Posts: 81
clarkie
Default

Hi,
Sorry to read about your troubles in Germany, the Galloper is sold there so you should have had no problem? I live in the UK (Scotland) and also have a Galloper but it is a 2.5 Turbo Diesel (1999/2000) model imported from Oman. Unfortunately you will NOT find a specialist in the UK and you will almost certainly not get any help from Hyundai. I think your best bet is to find an independant garage somewhere, small with enthusiastic and helpful guys in there to see what the problem is. It can't be much if the head gasget and thermostat have been changed? I also don't think running the engine with water instead of coolant/antifreesze mix will do it any harm in the short term, like 600 KM? The 3.0 litre engine isn't anything out of the ordinary and is probably much the same as the Mitsubishi 3.0 litre engine. The 2.5 TD is very much like the Mitsubishi 2.5 TD engine and is fitted in the Hyundai H100 vans so bits should be OK for mine however, I get my parts from Korea, they are cheaper and quicker believe it or not!! Unfortunately I am offshore just now, I could have sent you the Galloper service manual (albeit in Italian) which might have helped you, but probably not very much. As I said, find a little enthusiastic garage somewhere and explain the problem and see what comes up? How long does it take to 'overheat' anyway? Let me know how you get on
Alan Clarke
UK
alanclar@gmail.com
clarkie is offline   Reply With Quote Quick reply to this message
Old 04-28-2008, 06:38 AM   #5 (permalink)
Junior Member
 
Join Date: Apr 2008
Posts: 11
rohitbd
Default

Hi, I had this problem once and it all boiled down to a faulty radiator blower relay. So check if the blower runs automatically when the engine heats up. If not then check the blower and associted circuitry.
rohitbd is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:04 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.