Strut Top Roller Bearing - Hyundai Forums : Hyundai Forum

Register Home Forums Active Topics Photo Gallery Garage Members List Calendar Auto Loans Search Today's Posts Mark Forums Read Auto EscrowInsurance

Hyundai-Forums.com is the premier Hyundai Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-05-2009, 02:14 PM   #1 (permalink)
Junior Member
 
Join Date: Feb 2008
Posts: 2
leanish
Default

Hi there,can anybody tell me if they have had any problems with the strut top roller bearing,i replaced the drivers side on my 52 plate trajet last year and it has gone again.I have also had problems with my ABS ring,i bought a new ring on ebay but it never fitted so i welded the old 1 and stuck it back on with chemical metal.
leanish is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-06-2009, 03:22 AM   #2 (permalink)
Member
 
andycarter's Avatar
 
Join Date: Jan 2009
Posts: 59
andycarter
Default

Hi Leanish.

I think mine could be on its way out but haven't taken it apart yet.

What are the symptoms of this failure?
andycarter is offline   Reply With Quote Quick reply to this message
Old 04-06-2009, 07:35 PM   #3 (permalink)
Junior Member
 
Join Date: Feb 2008
Posts: 2
leanish
Default

Hi Andy carter
The first time the bearing went it was obvious the steering made a clanging noise when you were turning which got steadily worse.This time there is no noise,i only noticed because i was sorting out the ABS ring.new bearing with postage is costing 87 from dealer.
leanish is offline   Reply With Quote Quick reply to this message
Old 04-10-2009, 03:58 PM   #4 (permalink)
Senior Member
 
Join Date: Dec 2005
Location: ESSEX
Posts: 460
Hyundaiownersclub
Default

Water drops down from the scuttle panel above. You have to remove the scuttle cover and put a beading of sealant across the front edge and a modified strut cover. Usually the drivers side mount goes bang
__________________
HYUNDAI TECHNICIAN BASED IN ESSEX UK. ALL HYUNDAI REPAIRS/MODS UNDERTAKEN INCL ENGINE/GEARBOXES Hi Scan and GDS equipment... www.hyundaiownersclub.co.uk / www.essex-tech.co.uk
Hyundaiownersclub is offline   Reply With Quote Quick reply to this message
Old 04-11-2009, 03:00 AM   #5 (permalink)
Member
 
andycarter's Avatar
 
Join Date: Jan 2009
Posts: 59
andycarter
Default

Is there a diagram showing where to put the sealant and a part number for the modified cover?

Thanks!
andycarter is offline   Reply With Quote Quick reply to this message
Old 04-12-2009, 03:34 PM   #6 (permalink)
Senior Member
 
Join Date: Dec 2005
Location: ESSEX
Posts: 460
Hyundaiownersclub
Default

QUOTE (andycarter @ Apr 11 2009, 07:00 AM)
Quote:
Is there a diagram showing where to put the sealant and a part number for the modified cover?

Thanks!
You have to remove the plastic surround over the wipers,then the panel they(wipers) are bolted to. Below that is the lower scuttle-the front edge of this should be sealed. If you have fitted a new mount you should be automatically supplied with the new cover although its down to the partsperson .....
__________________
HYUNDAI TECHNICIAN BASED IN ESSEX UK. ALL HYUNDAI REPAIRS/MODS UNDERTAKEN INCL ENGINE/GEARBOXES Hi Scan and GDS equipment... www.hyundaiownersclub.co.uk / www.essex-tech.co.uk
Hyundaiownersclub is offline   Reply With Quote Quick reply to this message
Old 04-13-2009, 03:57 AM   #7 (permalink)
Member
 
andycarter's Avatar
 
Join Date: Jan 2009
Posts: 59
andycarter
Default

QUOTE (Hyundaiownersclub @ Apr 12 2009, 07:34 PM)
Quote:
You have to remove the plastic surround over the wipers,then the panel they(wipers) are bolted to. Below that is the lower scuttle-the front edge of this should be sealed. If you have fitted a new mount you should be automatically supplied with the new cover although its down to the partsperson .....
I had a look yesterday. The skuttle panel doesn't have any sealant at the front, just a rubber clip-on strip.

My RHS / Drivers side mount is missing its cover and it rattles when there's no weight on it. The LHS mount had lots of grease under its cover so assume the RHS should have also had some grease on it but didn't.

RHS Shock is also leaking and has minimal damping on that side so I'll be doing them both next weekend.

Can I get these items through HOCGB? Any aftermarket brands or motor factors to avoid or recommend?

Thanks for all the advice!
andycarter is offline   Reply With Quote Quick reply to this message
Old 04-13-2009, 06:13 AM   #8 (permalink)
Senior Member
 
Join Date: Dec 2005
Location: ESSEX
Posts: 460
Hyundaiownersclub
Default

QUOTE (andycarter @ Apr 13 2009, 08:57 AM)
Quote:
I had a look yesterday. The skuttle panel doesn't have any sealant at the front, just a rubber clip-on strip.

My RHS / Drivers side mount is missing its cover and it rattles when there's no weight on it. The LHS mount had lots of grease under its cover so assume the RHS should have also had some grease on it but didn't.

RHS Shock is also leaking and has minimal damping on that side so I'll be doing them both next weekend.

Can I get these items through HOCGB? Any aftermarket brands or motor factors to avoid or recommend?

Thanks for all the advice!
Email me through HOCGB with your chassis no and when I get chance I will put the mod up on that forum.
__________________
HYUNDAI TECHNICIAN BASED IN ESSEX UK. ALL HYUNDAI REPAIRS/MODS UNDERTAKEN INCL ENGINE/GEARBOXES Hi Scan and GDS equipment... www.hyundaiownersclub.co.uk / www.essex-tech.co.uk
Hyundaiownersclub is offline   Reply With Quote Quick reply to this message
Old 04-19-2009, 06:39 AM   #9 (permalink)
Member
 
andycarter's Avatar
 
Join Date: Jan 2009
Posts: 59
andycarter
Default

All sorted now!

Hyundai only sell the strut top covers in packs of 10, so I have a few spares - if anyone needs one just send me a message.

Thanks for all the advice / tips
andycarter is offline   Reply With Quote Quick reply to this message
Old 04-29-2009, 07:03 AM   #10 (permalink)
Member
 
Join Date: Apr 2007
Posts: 31
trajetheadache
Default

Agree with above.

I had the same problem on the drivers side and has been replaced twice. The second time, the garage told me that water had been getting into it and they had sealed it. Hope that this one lasts....
trajetheadache is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:33 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.